How to change OneDrive account for sync on Android?

Operating system


Joplin version


Sync target


What issue do you have?

I have two OneDrive accounts. When I configured sync with OneDrive I entered the wrong OneDrive user. I did not find any help (in this forum and elsewhere) to reset the settings for sync. I haven't found any profile files I could delete to force a reset. A new installation also did not help.

What can I do?

I think first configuring the necessary settings on the computer and then reinstalling the application on Android might be a solution.

I guess that I have expressed myself not very well. There is nothing wrong with the OneDrive accounts. I just want to switch sync on the mobile device to the other OneDrive account.

I am also saying that the way to do this may be to restart the synchronization process from the beginning for both PC and mobile. That's my thought. If I'm wrong, someone else can correct it.

Thanks for your thoughts. I do not understand what the PC has to do with the problem. Everything works perfectly on my PC and on another mobile. I just have entered the wrong account on one mobile accidentally (I have two OneDrive-accounts) . What do you mean by restart? The sync works. But it syncs with data on OneDrive-account "b". But I want to sync with OneDrive-account "a". And I don't know how to specify "a" somewhere as account because the prompt for this does not appear because Joplin has still stored a token for "b" somewhere (as I guess from other posts on how it works).

You're welcome. I'm just telling you what I would do as another user in such a situation. I had a similar situation before. I had tried "Webdav" and "S3" as synchronization targets. It was a long time ago, but I remember being able to log back into my OneDrive account from my mobile without the need for a computer. Have you tried solutions like uninstalling and reinstalling the mobile application? I think that's what I did.

Also, it would be a good idea to export and back up your Joplin notes on your computer until the process is completed.

I may be wrong but I think the only way is to reinstall the app.

I have reinstalled the app several times. No success. I think that there must be a kind of store for the token or whatever for persistence that must be deleted. This does not seem to be deleted on uninstallation. I am not an Android developer. So I do not have experience where these things usually are stored on Android (file system, database, vaults).

How have you uninstalled the app specifically? Android normally deletes all app data when you uninstall it (unless you use a special command with adb which I assume you do not). What kind of Android device is this? Is it something uncommon/unusual running a heavily customised version of the OS?

It is a Samsung Galaxy Tab S9 with Android 14. (Un-)installation via Playstore. No customziation of the OS.

I have uninstalled the app, shutdown and startet the tabled. Then it worked. I had to enter the OneDrive Account.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.