Feedback on GUI editor: no option for tabs to be spaces

I am using Joplin 1.0.201 (prod, darwin) and Vim keyboard mode. I have plugin soft-breaks enabled. (I am referring here to the regular markdown editor (split mode) and not the experimental WYSIWYG editor).

Problem: When using the default editor and am typing non-ordered lists (with -), when I have indented sub elements on the list (see below for example, -two is a sub-element), use of the Tab key uses 4 spaces and inserts a hard tab.

- one
    - two

I would like there to be an option for soft tabs (convert to spaces) and the number of spaces in the editor.

(I attempted to use regular vim commands such as set tabstop=8 softtabstop=0 expandtab shiftwidth=4 smarttab, but these provoke an error "Error: unkown option: ")

Thanks for all the awesome work being put into Joplin, I use it all day, every day.