Any way to use spaces instead of tabs in editor?

Hi, I surely missed a setting but I was wondering:

Is there a way of using spaces instead of tabs when using ? i.e. for indenting lists

I’d like 2 spaces instead of a 4 spaces tab when indenting. I’m wondering if that’s possible?

I saw a few threads about that but none with any interesting suggestions/answers.

Thanks!

9 Likes

Bump.

I’d also like tab to be 2 spaces as opposed to 4. Whether it keeps it as a tab code or 2 spaces, I’m indifferent there.

2 Likes

It depends where you want to see that.
In the editor, it is not possible (unless some setting is added): tabs are transformed to spaces by the Ace editor, but still behave as tabs…
In the rendered Markdown, you can change the tab width with userstyle.css:

#rendered-md {
	tab-size: 12;
}

Now, you can type two spaces instead of the Tab key… It is more annoying for larger widths.

I was hoping to see it change on the editor side as well personally.

2 Likes

If you switch to the CodeMirror editor (In Options > Note), you can try this userchrome.css trick:

.cm-tab {
  font-size: 4px;
}

Warning: might have side-effects (or might not work, have no time to try for real).

Any progress on this? I find this behavior to be odd. When I try to copy my markdown somewhere else, the tabs for indented list items seem to break the formatting. I'm new to markdown, but I thought one of its strengths is the lack of "hidden" characters?

I have to edit any pasted markdown to replace tabs with spaces.