Failed import of a single note from Evernote enet export - Span tags?


I've recently imported a number of notebooks successfully from Evernote ENET export files. I had one notebook that stalled during import, and was able to isolate a single note that fails. I've moved that single note into a separate notebook and ENET file to isolate the problem. The log file contains multiple instances of "Unsupported note tag: span". I'll attach the log file and single record ENET file.

This is low priority as it is only one record, and I can simply copy it manually if needed.

  • Joplin Version: 2.3.5 (prod, darwin)
  • MacOS Catalina version 10.15.7 (19H1323)

Could you attach the file that's causing problem please?

Apologies, thought I had.

Note from Meeting for Opportunity US Department of Justice with Rich Baumel needs coverage. SC Federal, this has been assigned to your group. SCACT0042963 in Arlington..enex (65.0 KB)

And the log: ImportLog-MacOS-oneBrokenRecord.log (386.8 KB)

The ENEX file was corrupted, which is why it couldn't be imported. In fact, even Evernote cannot import it (it results in a empty note body). Was that file generated by Evernote or by some other app?

In any case, I've added a small hack to handle this issue in case it affects other existing notes.

Thank you! Apologies... I should have tested importing to Evernote previously myself. I've tried it now and saw the same error.

No worries, I mean it's reasonable to assume that the note would work in Evernote. So was it initially exported from Evernote or from another app?

It was originally exported from Evernote on MacOS.
Here is the version info from the "about" menu:

10.21.5-mac-mas-public (458776)
Editor: v131.1.16771
Service: v1.39.1
© 2019 - 2021 Evernote Corporation. All rights reserved

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.