Extremely slow start


For bug reports, please post them on GitHub - Issues · laurent22/joplin · GitHub
If you are not sure if it's a bug or not, PLEASE POST ON GITHUB ANYWAY.
If you post a bug report here, we cannot track it and there's a chance it won't be looked at and fixed.

For other support queries please indicate:

  • The version you are using. LATEST VERSION is not a version number!
  • If it is a sync issue, please let us know what you are syncing with.
  • If you report a problem with upgrading, please let us know both versions (from/to).
  • If you report a problem with the editor, please tell us which editor you are using (WYSIWYG/Markdown).
  • The operating system you are using.

If you can also please provide a log, as described here: How to enable debugging | Joplin

Posts that do not at least state the version number and operating system will not be answered.

Joplin 2.9.17 (prod, win32)
Windows 11 PRO (22H2)
Dell XPS 11th Gen Intel Core i9-11900K, 32 Gb memory

I do not remember when it started, but now Joplin takes 30 seconds to show up after I start it. I tried disabling all plugins, it did not help. (I saw other posts (in 2021 and 2022) reporting plugin issue and 5 minutes delay, I think my issue is different.)

Same here: Joplin 2.9.17 (prod, win32), Windows 10, slow start. As it's the portable version I always assumed it to be normal that it takes around 30 seconds to show up.

The portable one can be very slow to start as it needs to unpack itself every time, and this its highly dependent on the CPU and disk performance (and also possibly the antivirus).

The normal installation shouldn't need more than a few seconds though, unless the hardware is really weak.

So maybe it's time to change my setup which consists of one windows installation and half a dozen portable versions on several notebooks and flash drives.

To do so: Is there a shortcut to switch from portable to installed version on the same device without resorting to re-download from remote storage? What I have in mind is this:

  1. Delete Joplin.exe, keep JoplinProfile directory
  2. Install Joplin desktop app
  3. Delete contents of newly installed profile folder
  4. Move contents of portable profile folder where the installed profile folder is located
  5. Run desktop app and hope that all will be sound and well...

Is this method recommendable or likely to cause havoc? I could of course use the profile folder of my one and only installed version as a source for copying the data over as well.

  • version 2.9.17 (prod win32)
  • syncing with onedrive, but that is probably not the issue.
  • operating system windows 11 pro 22H2

The installed version was opening in seconds. The portable (same version) was taking 30 to 60 seconds to start on the same machine. I synchronized both via onedrive. I also put the portable version into a folder OTHER THAN the apps folder (the joplin sync folder) and let it sync to a laptop. I then started the portable version on that laptop after the s/w and profile had synched (onedrive sync). It worked fine, although startup was a bit slow as expected.

problem: now the installed permanent non-portable version takes 30-60 seconds or longer to start on the original machine. I tried removing everything related to joplin on both machines and onedrive and the registry and the appdata directory and reinstalled. The installed version on the main machine continues to load slowly.

Any ideas?

edit: ps, I did save as a single jex before wiping everything out and restored that jex afterwards, but not any of the ini nor sqlite. I also was surprised to find parts of the portable app in my user profile appdata folder but I deleted that, too.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.