Home / GitHub Page

External editor in windows

#1

Hello,

I would like to use MarkdownPad2 in my Windows as external editor in Joplin.

if I use
c:\Program Files (x86)\MarkdownPad 2\MarkdownPad2.exe
I get error message spawn c:\program NOENT

or if I use
Program Files (x86)\MarkdownPad 2\MarkdownPad2.exe
I get error message spawn program NOENT

What is wrong?

#2

You are getting errors, because you have spaces in the path. I don’t know how to fix that on Windows.

Try to use double quotes around the path: "c:\Program Files (x86)\MarkdownPad 2\MarkdownPad2.exe"

#3

Any solution to this issue yet? I’m also having an issue where I can’t reset the default editor that I picked for Joplin.

#4

Next version will be better for selecting external editor. Meanwhile, you need to add double quotes around the path if it contains spaces.

What do you mean you can’t reset it?

#5

Hey Laurent,

I should have been more clear, my apologies.

First time user here, installed yesterday to try out Joplin since its feature set is right up my alley. I am very happy to see E2EE and nextcloud support!

In my testing, I was just clicking all the buttons on the main editing interface to get a feel for Joplin. When I clicked the external editor button, windows popped up the “which default program to use” dialog, and without thinking, I selected Chrome. Oops. From that point onward, it opened all the files in chrome, which isn’t super useful :grinning:

I did some digging and discovered the “Text editor command” property in the settings, which I promptly attempted to drop NP++ in. Unfortunately my install path has a space in it, and regardless if I use double quotes around the full path or not, I get this error:
image

Is there a way to reset the default editor (the one used when one is not specified in the Joplin settings)? Is that config stored in Joplin or in Windows? I tried looking in %appdata%, reinstalling, etc, but it never reset away from Chrome, and I never saw the window pop back up again. Perhaps my solution will just be moving NP++ to a directory without a space in it, unless I’m using the double quotes wrong.

Thanks for the quick reply and for developing this tool! It looks really promising!

Edit: Clarification