JoplinPortable 1.0.214 external editor problems

  • The Edit in external editor button has been removed but there is no mention of this in the release notes

  • The Text editor command path field is blank, i.e. it isn’t populated with the current saved external editor path (which is Notepad++ for me, and is working via Ctrl+E)


I can't replicate this. How do you know there's an editor path saved, if nothing is shown? Isn't it just using your system default text editor?

@laurent, because as I said Notepad++ runs and Windows system default editor is Notepad.exe?

To be more precise I should have said Notepad++Portable.exe runs and I’m used to Notepad.exe running for plain text files but on further study I see that I have associated .txt & .md with PA.c’s Notepad++. Apologies!

However cancel my post and replace it with a bug report? Updating JoplinPortable form 1.0.201 to 214 has caused the external Text editor command path to be lost. If that was by design it would need to be in the release notes?

Here are the before and after pictures.

Browsing the new database.sqlite I can not find the settings.editor key.

[Edit] To further understand I entered an editor path into the settings field and it worked (got added to the database.sqlite). So although upgrading loses the previous setting and the external editor button has been removed the feature is still there. However without a button to stop external editing how does the little square icon with a NE arrow next to the note title in the second column get removed?

May I also mention that there was no warning that the profile version was changing from 28 to 29 and thus one would not be able to revert back to 1.0.201 if one didn’t have a full profile backup?

1 Like

This is a problem when you do not have gvim installed, or when you simply prefer to use normal Vim from within your preferred terminal!