Error: EACCES: permission denied

I'm trying to install Joplin version 2.7.14 on my M1 mac,but I keep getting this error.

Fatal error
**EACCES: permission denied, mkdir '/Users/myname/.config/joplin-desktop'

Error: EACCES: permission denied, mkdir '/Users/myname/.config/joplin-desktop'**

I tried changing the permission ,but I'm still getting this error. I also tried different things that was posted in the Joplin forum and still didn't fix the issue. If you can help me, it would be great

What exactly have you done?

Did you change the owner of Users/myname/.config/ from root to your user?

After trying many different commands, I finally got it to work in my Mac terminal. This issue arises when the .config doesn't have access permission to the home directory and instead it recognize it as root permission. This is what I recommend doing if you had to deal with this issue.

1-Make sure you are in home directory. You can do that by using cd~ command and then pwd command to show you the home directory. Home directory is in the form of /Users/yourname or /Users/username.

2- Afterwards, you can use the command below to change the ownership of .config form the root to the user.
Command is: sudo chown username: /Users/username/.config

**Remember to replace the username with your own Mac's username by using step 1.

3- Enter your password.

4- That's it. Try opening the Joplin executable file. That should work.

I hope this help :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.