EACCES: permission denied,

Completed: 22/03/2021 07:30

Last error: Error: Error: EACCES: permission denied, mkdir '/home/avivilloz/.apps/joplin/locks'. Path: /home/avivilloz/.apps/joplin/locks

i tried changing permissions of the directory for all user to write but to no avail.

what should i do?


maybe filling out the template

what template?

This one, it shows when you create a new post in the Support section of the forum


For bug reports, please post them on GitHub - https://github.com/laurent22/joplin/issues
If you post a bug report here, we cannot track it and there's a chance it won't be looked at and fixed.

For other support queries please indicate:

- The version you are using. LATEST VERSION is not a version number!
- If it is a sync issue, please let us know what you are syncing with.
- If you report a problem with upgrading, please let us know both versions (from/to).
- If you report a problem with the editor, please tell us which editor you are using (WYSIWYG/Markdown).
- The operating system you are using.

If you can also please provide a log, as described here: https://joplinapp.org/debugging

**Posts that do not at least state the version number and operating system will not be answered.**

Joplin 1.7.11 (prod, linux)

Client ID: d06c467784a0430c8b076a80406d3897
Sync Version: 2
Profile Version: 34
Keychain Supported: No

Revision: f560563 (master)

it is a sync problem i'm trying to sync with file system, i specified a folder to it, but apparently it cannot access it, but i already changed the permissions to give access to it.

This sounds like you might be using the snap package which cannot access folders located in the top level of $HOME that are hidden, the official AppImage wouldn't have this issue, so if you're not using it that's probably the simplest fix and gets you proper support from upstream.

To work around it in the snap, you'd either need to disable it's sandboxing entirely (I.E, reinstall it with --devmode flag, sudo snap install joplin-desktop --devmode, but this disables automatic updates entirely and doesn't just simply make it equivalent to a normal app in every regard), move the sync target (maybe make use of a .hidden file so it doesn't appear without requiring a leading . ), or use a bind mount to make it appear at a valid location like a symlink would (but symlinks themselves don't work).

1 Like

thanks a lot for the answer, i downloaded the official AppImage and it worked fine!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.