Enter key after switching notes, the line spacing is large | 切换笔记后回车键 行间距很大

在刚开始输入的时候是正常的.按回车就一个换行. 但是如果切换到其他笔记本再进来按回车就是两个换行了。导致行间距很大 怎么着才能按回车正常显示啊

This post was flagged by the community and is temporarily hidden.

It is normal at the beginning of the input. Press Enter and one line feed. But if you switch to another notebook and then press Enter, it will be two line feeds. The line spacing is very large. How can I press Enter to display it normally?

More information would be helpful:

  • Are you using the desktop app or the mobile app (or the terminal app)?
  • Are you using the rich text editor (WYSIWYG editor)?
  • Does this happen if you switch to a different note? An empty note? Or just a different notebook?
1 Like

Hope these translator helps.

@krystal
你可以使用这些翻译工具。这是一个英文论坛,用英文能让你得到更多人的帮助。
This is an English forum. Using English will get you more help.

2 Likes

You can check the template to know what you need to provide.

For bug reports, please post them on GitHub - https://github.com/laurent22/joplin/issues
If you are not sure if it's a bug or not, PLEASE POST ON GITHUB ANYWAY.
If you post a bug report here, we cannot track it and there's a chance it won't be looked at and fixed.

For other support queries please indicate:

- The version you are using. LATEST VERSION is not a version number!
- If it is a sync issue, please let us know what you are syncing with.
- If you report a problem with upgrading, please let us know both versions (from/to).
- If you report a problem with the editor, please tell us which editor you are using (WYSIWYG/Markdown).
- The operating system you are using.

If you can also please provide a log, as described here: https://joplinapp.org/debugging

**Posts that do not at least state the version number and operating system will not be answered.**

As @personalizedrefriger said, the platform you are using and steps to reproduce the problem are also necessary.

你可以根据这个模板来提供必要的信息,一般包含以下几点

  • Joplin具体的版本号
  • 如果是有关同步的问题,你的同步目标是什么
  • 如果是有关升级的问题,新版本和旧版本的版本号是什么
  • 如果是有关编辑器的问题,你所使用的编辑器是什么(所见即所得编辑器/Markdown编辑器)
  • 你所使用的操作系统

如果可以的话,最好能根据 How to enable debugging | Joplin 上的步骤提供日志记录

如同 @personalizedrefriger 所说的那样,你正在使用的平台(桌面端/移动端/命令行)以及复现问题的具体步骤也能帮助我们找到问题所在。

There are two types of editor: Markdown editor and WYSIWYG editor(rich text editor). WYSIWYG editor will convert the formatted text into markdown to save it, and it will insert two linefeed when you hit Enter key once. I guess you are using Markdown editor at first, then you accidentally switched to WYSIWYG editor. That's why the behavior of Enter key changes. To make the spacing between lines narrow, don't use WYSIWYG editor. Daeraxa's post shows how to get a single line space in WYSIWYG editor.

Joplin有两种类型的编辑器,一种是Markdown代码编辑器,一种是“所见即所得”编辑器(富文本编辑器)。Markdown编辑器中一个回车输入一个换行,而在富文本编辑器中按回车键时,它会在Markdown代码当中插入两个换行,因此你会感觉两段文本之间多了一个空行。我猜测你一开始用的是Markdown编辑器,之后无意间改成了“所见即所得”编辑器,所以两次按回车键的效果不一样。你可以只使用Markdown编辑器,这样就能只输入单个换行。 按照楼下Daeraxa的方法你也可以在“所见即所得”编辑器当中输入单个换行。

You can use shift + enter in the rich text editor to get a single line space (i.e. <br>). By default enter creates a new paragraph <p>

2 Likes