Spacing between lines

Operating system


Joplin version


Desktop version info

Joplin 2.14.20 (prod, win32)

Client ID: f1b87d81f3ff4799a2e97e0e9e30f662
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: cfd98e3

Backup: 1.4.0

What issue do you have?

Perhaps this is the wrong category and if so except my apologies in advance. My question is this: How do I control the spacing between lines? When I press the enter key it creates the big space between the lines. Is there not a way to change how big that space is? I've attached a screenshot to show what I'm talking about. I'm referring to the spacing between the line that starts with The HEOS Link... and the line It adds music...


Try doing a shift return rather than just pressing the return key and see if that gives you better results it works most of the time in many apps.

1 Like

Apologies for the delayed response. This solution did resolve the problem.

Thank you

1 Like

Is it me, or do others think it's weird to have to do a Shift/Enter to get a single line when doing a return?

1 Like

Not really. The same function Works in many Windows apps. If I want to change the spacing in apps I can get the lines closer together if I use a shift enter.

Same feature in Joplin for Linux. I use both.

I use both too, but I have to say that I've never had the line spacing issues with the standard windows notepad or most of the "notepad like" editors in Linux. The only place I sometimes have the line spacing issues is when I paste something into MS Word or the Libre Office editor.... And Joplin


You won't see this problem in the plain text editor. Joplin is more than a notepad editor.
With notepad every single line and the letter are exactly the same size and in markdown you can have fonts that are different sizes so that's probably what introduces the spacing problem.

I do see it in the Joplin notepad as well as the Joplin Markdown editor. Not sure if that's what you meant to say, but that's what I'm seeing with Joplin.

Yeah, I'm with you, I'd prefer it to be the other way around. But my biggest issue with it was definitely how it treated my imported Evernote notebooks though, completely screwing up the formatting of anything with linebreaks, and not even being consistent with it. Sometimes it decided a single linebreak didn't exist at all and put multiple lines that were supposed to be on different lines on the same one, and sometimes it decided a single linebreak was actually one of those double-spaced linebreaks. Anything with more than one linebreak was treated as a singular linebreak, too. So quite a bit of reformatting to be done to get those imported notes back into a useable state.

This is the default of Microsoft Word, which is the de facto standard when it comes to word processors. The best would be to just make it a configurable option. This way, anyone would just be able to change the defaults according to their own preferences.

Bingo! That's exactly what happened to me, I imported a ton one MS OneNotes and it randomly added double line spacing everywhere... I'm still cleaning up.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.