Endless sync, Victor not working either

  • Joplin 2.12.18 (prod, win32) for Desktop, on Windows 11
  • Syncing with Joplin Cloud

I'm trying to start over, used Victor to delete. Victor seems to have completed, but Joplin Cloud still has 40MB.
So I did the "Delete local data and re-download from sync target" which goes on endlessly, also won't let me cancel.
According to Sync Status, I now have 0 notes (thank you Victor), but thousands of NoteTags and Revisions.

This is similar to the topic "Failing to delete all data on Joplin Cloud", but it was closed without a solution.

I've also posted on Github in case it is a bug. It might be just me, though.

Anyone here bumped in to a similar issue and solved it?

Victor was updated to v1.0.1 yesterday and now "All notes, notebooks, attachments, tags and revisions are deleted."

Have you tried that version yet?

1 Like

Thanks @dpoulton !
Now I am stuck at "Deletion in progress..." for an hour. I'll leave it for a while and see if it changes.

+1 (but I not use victor, joplin app use only)
I remove more notetag object
I canceled the synchronization process midway, and then the next synchronization would hang and there would be no response.
I see the log, suspected hang then not send lock file, so lock file timeout

To delete the revisions too, please make sure you use the latest pre-release: Release v2.13.2 · laurent22/joplin · GitHub

Is there any error in the console? How to enable debugging | Joplin

I posted that one, and I allowed the thread to close without indicating a resolution. My issue was resolved through the troubleshooting efforts of @dpoulton, @laurent, and support at Joplin Cloud.

I'd suggest systematically incorporating their suggestions into your own efforts to find a fix, and being transparent about your ongoing needs.

Thanks @candrak , @laurent

Not sure, but Joplin went in to a round of RevisionService being disabled, so something may have gone wrong.

2023-10-08 10:55:02: RevisionService: "maintenance: Starting..."
2023-10-08 10:55:02: RevisionService: "maintenance: Service is disabled"
2023-10-08 11:05:02: RevisionService: "maintenance: Starting..."
2023-10-08 11:05:02: RevisionService: "maintenance: Service is disabled"

I next tried

  • Joplin v2.13.2
  • Victor v1.0.1

Victor succeeds with "All items have been deleted" but the Synchronizer goes on to update NoteTag on Joplin Cloud, and the local database.sqlite is still 240MB.
Synchronizer: Sync: updateRemote: local has changes: NoteTag: (Local 49f91cc3fded48de93d0430f2f7359dd): (Remote 49f91cc3fded48de93d0430f2f7359dd.md)

The revisions table in database.sqlite is empty now. Progress! Thank you for the update, Laurent!
But the note_tags table has a lot in it. This may be the issue. Is it possible for Victor to delete that table, too? Or would it break something else?

If you want to "start over" and you are happy that the server has been cleared out you can "reset" Joplin and its database to defaults.

Fully close the Joplin client (File > Quit) and then rename C:\Users\<username>\.config\joplin-desktop to something like C:\Users\<username>\.config\joplin-desktop-old and then restart Joplin. Joplin will be as if it had just been installed with just the default notes. You will have a new joplin-desktop folder containing a new database.sqlite.

When you are sure you do not need it you can just delete C:\Users\<username>\.config\joplin-desktop-old.

Thanks for checking this!

The thing is, I've tried. I even have a joplin-desktop-bak folder to prove it :laughing:
I can't seem to completely clear out Joplin Cloud, the data seems to be equivalent to the database.sqlite file. I can "reset" Joplin, which then goes back to my first post. "Delete local data and re-download from sync target" takes a long time to sync, with zero notes but a lot of note_tags. Victor won't delete these.
I also tried "Re-upload local data to sync target" but that also proceeds to downloading the remaining differences, again the note_tags.
If I was syncing on my own cloud, I would probably just delete the remote directory and start over. Joplin Cloud doesn't allow that.

Any other way I can clear out Joplin Cloud? Or any way (Victor?) to delete the note_tags table, too?

I considered editing the database.sqlite myself, but there are tables like deleted_items and item_changes that have a lot in it. I didn't think it would be a good idea to simply edit database.sqlite, since I wasn't sure how the tables are linked. I would probably break something and start asking for even more help.

Hi all that participated, thank you for the advice.
I've given up on trying to completely clear Joplin Cloud, especially NoteTags.

To close off the thread for those that come here with similar problems:

  1. This is only for Joplin Cloud users. If you are using other ways to sync, you have control to clear out all remote files, including database.sqlite.
  2. If there are no errors, the sync is probably not endless. Mine took days, not just overnight, but still not endless.
  3. Once the sync completes, there is little overhead in syncing the updates. The long sync time will only be an issue with a new device or a new install and first sync.

I will still continue to use Joplin Cloud, because I find value in the email import function.
Love Joplin and will continue to support, the best.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.