Drag-n-drop of files from linux file manager to editor only works after a random number of attempts

Operating system

Linux

Joplin version

2.14.22

Desktop version info

Joplin 2.14.22 (prod, linux)

Client ID: 9959465eea794e60b1b95760c308ca91
Sync Version: 3
Profile Version: 46
Keychain Supported: No

Revision: e579eb9

Automatic Backlinks to note: 3.0.3
Backup: 1.4.1
Combine notes: 1.2.2
Conflict Resolution: 1.2.3
Favorites: 1.3.2
Hotfolder: 1.2.0
Inline tags: 1.3.0
Inline TODO: 1.7.1
Kanban: 1.1.0
Link Graph UI: 1.5.0
Markmap: 1.7.0
Note list (Preview): 0.4.1
Note overview: 1.7.1
Note Rename: 1.0.0
Note Tabs: 1.4.0
Outline: 1.5.13
Quick Links: 1.3.2
Space Indenter: 0.2.5
Tagging: 1.0.3
Templates: 2.4.0

Editor

Markdown Editor

What issue do you have?

This has been happening for a long time.

  • I open the file browser (GNOME on Fedora 40)
  • drag a file into the editor (Markdown editor)
  • nothing happens
  • try again
  • nothing happens
  • try again
  • nothing happens
  • try again
  • WORKS!

(the number of attempts varies; sometimes works on the first go, but not usually)

And sometimes, when it "works" it will just insert the filesystem path to the file I dragged into the editor.

So strange. Happens on both of my laptops (same versions of everything).

This has been the typical behavior for a very long time. I just never griped about it because I only used it here and there. Lately, I have been using this feature more and now it is officially a PITA.

I can't be the only one. Anyone else?

Is the file manager in Fedora 40 "Files" like Gnome / Ubuntu?

I just installed Joplin 2.14.22 on an Ubuntu 22.04 VM and if I drag & drop from "Files" into the markdown editor I mostly just get the file path. Very occasionally either the file does import properly or nothing happens. If I drag and drop from the desktop the files import correctly every time.

Using Kubuntu 22.04 and KDE's "Dolphin" I get a proper import from drag & drop into the Joplin 2.14.22 markdown editor every time.

Finally I installed Joplin 2.14.22 onto Linux Mint 21.3 Cinnamon and drag & drop from "Nemo" into the markdown editor works every time.

So if you are using "Files" it appears you are not the only one, but there does appear to be something special about "Files" / Gnome.

Yes. Fedora GNOME and it's default file manager, Nautilus (that's its project name, it comes up as "Files" as an app name). It's interesting that you get the path more often than not. Nautilus is something like ... 23 years old. So, all the crusty bits should be ironed out by now. One would think anyway.

Version info: Nautilus (or Files) v46.1. I have the Sushi plugin installed with it which provides facility to see certain previews of files.

I use GNOME. There is no desktop. :slight_smile:

My copy of Ubuntu 22.04 shows the file manager version as 42.6 and its copyright date is 1999!

Or it is just too old? Is it possible to try another file manager to find out if it is Nautilus / Files or the underlying desktop environment?

It must be an Ubuntu thing as it will let you place files on the desktop in Gnome 42.9. That is how I managed to copy them into Joplin! :slight_smile:

You only ever have to show the initial copyright date for something. You don't have to "renew" it. :slight_smile: GNOME was launched in 1999. Nautilus was launched in 2001.

Files (aka Nautilus) is the default GNOME file manager and it is well maintained.

I installed Dolphin and Nemo (Nemo is a fork of Nautilus) on my Fedora installation. Same behavior was on display.

Saving stuff to the desktop. You turn that on with a GNOME Extension. I did that and … The behavior is the same. :frowning:

I turned on debug mode and nothing obvious is going on. No error message that I could see.

Wee!

I realised that I just meant that some of the code may be old :slight_smile:

Anyway, Linux Mint has Nautilus in its software store (v42.6). I installed it and it worked perfectly when dragging and dropping files into Joplin.

As I am sure you have gathered I have no idea what may be happening but at least you now know that it isn't something unique to you...

It's just an observation and very likely just a coincidence but of the three distros I tried Ubuntu was the only one where I had to install libfuse2 to allow Joplin to work.

I should note that this issue has been lingering for a long time for me (I am pretty sure since at least GNOME version 42 (Fedora 36)). I just didn't report it because ... I was being lazy and didn't use the feature all that often. Kinda like the "Save as" file manager always opening below the Joplin window when I do exports to PDF and similar. Annoying, but doesn't wreck my workflow.

Anyway. How should we file this issue?

I am another user like yourself but if the logs are not showing anything and there is nothing that can be pointed to in Joplin that needs looking at or fixing, I am not sure what can be expected.

At this time it does not appear to be able to determine whether this is being caused by GNOME, the AppImage, Electron, Joplin, a combination of them, or something else...