Help: drag and drop image broken on release 1.0.207

Hi, please help?

I am on latest 1.0.207 on Win10 and when I drop an image, Joplin goes completely white, except for the menu-bar (which still works), When I close Joplin and open again, the image was not included in the mark-down of the note. I have cleared my userstyles and userchrome completely empty with same result.

The image is a png of 1,62kB, which would be completely normal. I tried with jpg format – same thing.

I tried to revert to old release, but that will not start-up anymore, telling me i probably use an old release…

Which editor?


Is the note you are placing the image in located in a set of nested notebooks?

If so this github issue may be what you are experiencing

Hi Laurent,

In the old editor, so no WYSIWIG. I have restarted the computer and white screen issue seems to be solved. But the image does not drop on the cursor location, but top of the note as the very first characters in the markdown. I am relieved, there is a workaround now, but a little annoying…

Is it only with drag & drop? can you still attach using the “attach file” button?

Attach file now seems to work (did not before) at the correct cursor location, and drag and drop still not on the cursor but on top-of-note

No the note is in a root notebook

The whole source editor is a bit buggy, the screen keeps jumping to end-of-note during editing, after I attach file an image. I need constantly to scroll up to get back to my cursor where I am editing.

Looking at the release notes it seems that this pre-release version (1.0.207) contained a rewrite of the note editor.

"pre-release rewrite": I can understand that there are some wrinkles than. In the end it will be an improvement no doubt. For a user it is a little confusing that not the expected results appear, could be simple issue or very difficult to chase issue. I will be patient :wink:

I think this issue and others related to file attachments is fixed but not yet released.