[resolved] Encryption does not work when seting up two devices

Tech details:

  1. Ubuntu 22.10. Joplin installed as App Image.
    Joplin 2.5.12 (prod, linux)
    Client ID: ba0a0858d2c2417c9a7588f3772194bb
    Sync Version: 3
    Profile Version: 39
    Keychain Supported: No
    Revision: 884b86f

  2. Android 12. Joplin 2.11.32

The problem: when I setup encryption on android I cannot see notes in desktop. There were various attempts to fix the problem and now I am down to basics.

I clear app data on Android. Start app. It has welcome notebook. I delete it, create new notebook with one note. Enable sync to dropbox (previously I used webdav, tai it's first time to dropbox). Enable encryption.
Now I start clean app on desktop. It has welcome notebook. I deleted it. Enable sync. Enter master password. Now I cannot see notes because it just displays encrypted. Master password displayed as Valid.

Then I tried to setup starting from desktop. Without encryption everything works. When I enable on desktop and sync - it works on desktop. But as soon as I add android and setup master password - I can see and edit on android, but not on desktop.

There is only one encryption key. i.e. I did not create different ones on both app, only one where I enable encryption.

I have reset and did this process multiple times and still no luck. I think I am going crazy... :confused:

It seems I do everything how I should and searching internet come with answer like multiple encryption keys and similar.


@aurelijus welcome to the forum.

It is possible it is because you are not using a recent desktop version of Joplin. The Android 2.11.32 client is recent and using 256-bit encryption by default. The desktop 2.5.12 version is old (8 Nov 2021) and limited to 128-bit encryption.

Well, wow. So I am not crazy, just a bit stupid :smiley:
Great, it works! The fact that the app images do not update themselves skipped my mind.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.