I have some problem with Encryption

Hello there, I might have missed something while activating encryption in Joplin.

What I did was following the 1 to 5 steps in the documentation to encrypt my notebooks on my Mac. After that I downloaded Joplin for Android and I repeated the steps to get the encryption there as well.

The thing is now in the Encryption tab (under preferences) I have two Master keys.

I told myself, well, I’m just gonna disable encryption and start over. I disabled the encryption on the computer, synchronised everything again. In the Encryption tab I have displayed “Encryption is diabled” and “Decrypted items: 64/64”

The problem now is that

  1. when I synchronise with my mobile device half of the notebooks are still showing as “Encrypted” and I can’t access them;
  2. In the encryption tab in both device I still have two master’s key, how can I have only one?

You shouldn't repeat the steps. Step 6 says to repeat only step 5, otherwise you indeed end up with multiple keys.

You need to input the password for these other keys if you want your notes to be decrypted.

Cool, thanks for the clarification! How can I remove the second key now?

It’s not possible. There could be an option to hide it at some point, but for now the keys are always shown in the list.

Alright, one last thing: I have disabled encryption on my computer, I synchronised everything but when I synchronise on my phone I still get encrypted notes and the notification on the top: “Press to set the decryption password” how can I completely disable encryption?

For now, you’ll need to enter your password for the notification to go away. Your notes won’t be encrypted in any case.

Cool, now I can see all the notebooks even from my mobile!