Database on 1 device not updating correctly


Not long ago i switched my database from one cloud service to another. I got that working properly.
But i do have a PC i am not on a lot. But now i tried to change the webdav url to the new one. This worked and i do see all the new notes i made in the time between the switch and getting behind this PC but there are some notes that do not update properly.

For example. In a note on my Laptop and mobile it says a + b = c while on the PC its still saying a + b = d. Even when i synchronized everything.

Another example: I have a list of music i still need to check out and added a few new bands to it but those newly added are not appearing in joplin on the PC.

The version of joplin is 1.0.216

Windows 10

thanks in advance

no one ?

I am not sure, if I understa dn you correctly, because the text makes only partly sense.

Do you mean you changed the sync target from one cloud provider to another?
There’s a guide how to do that properly.

Does any of your clients have a Conflicts folder. It seems that you might have conflicts that have to be resolved.

Thank you for your reply.
Sorry if it’s not clear what the problem is. I’ll try to explain it again.

I have joplin op my phone, laptop and PC. I do not use my PC very often so it usually runs behind a bit on updates and such. Recently I changed the cloud storage according to steps I found on here and all worked fine on my laptop and phone.

So I added a lot of new notes in Joplin on my laptop and synced it all to my phone.

Couple of days later I went on my PC, updated Joplin, changed the cloud webdav and let it sync. I saw all the new notes appear properly but when I check the notes that were already in Joplin before the cloud change they do not contain the changes I made in them.

So I also would think it would give conflict files but no. There are no conflicts found. That’s the strange thing.

I tested the sync by adding a new note on my phone and that did appear on the PC. Yet the pre-cloud change notes do not update

It’s hard to determine the problem, if there aren’t any errors in the log. I suggest to do the following:

  • export all your data to JEX on your laptop (that’s the one with all the correct data, right?)
  • delete your profile directory on the PC (this will delete all local notes and your settings)
  • start and setup Joplin again on your PC - theh sync
1 Like

Thank you for your reply. I will try this somewhere this week when I’m at my PC. I hope and think that should work indeed. I will let you know.

Joplin on the PC is still syncing everything but it seems this will work indeed. Thanks a lot

You are welcome.