"ctrl+v" "ctrl+a" does not work(solved)

As you can see in the video, these two shortcut keys are disabled.

Both work fine for me in the dev build of 2.9.4.

But all the software works fine, except for joplin, there is no way I can do it.
This has nothing to do with the version, I have just reinstalled back to version 2.8 and it still does not work.

What keyboard layout are you using? Wonder if that might have anything to do with it. For example does it work if you use US or UK layouts?

I tried again to reinstall joplin and this time the problem was solved.
And I found the real problem, it was caused by the wrong settings file, I don't know what the problem is with this setting file.

When I want to reinstall joplin, I'm used to saving the settings file separately and then uninstalling it. When I install joplin,I'll replace joplin's settings file with the saved settings file. It was this document that led to the error.

By the way, is there something wrong with my operation of replacing the settings file, and what caused him to go wrong. :pray:

I don't think so? You could check if your original settings.json file was broken somehow by opening the dev version (Help > Copy dev mode command to clipboard) and replacing the dev mode's settings.json file (it is the same place as the normal one but called joplindev-desktop.

If it does break it then it might be worth posting a copy here (just check it in case there is any data you need to delete) to see if we can also replicate it.

It has been tried and there is indeed a problem.

There is another point I did not mention, the S3 secret key information in the setting file is always missing, the rest of the information is complete, I don't know what the reason is.

settings.json (1.4 KB)

Sync target passwords and other secret info doesn't get stored in the settings file or database. I think it goes into the keychain (or similar things on other OSs) where it is safe rather than storing it in plaintext.

"editor.keyboardMode": "emacs"

You have it in emacs mode. Copy in emacs is alt + w and paste is alt + y

1 Like

Thanks, I've changed to default. There's also a problem, when I want to look at "Custom stylesheet forrendered Markdown" and "Custom stylesheet for Joplin-wide app styles", clicking on it doesn't respond.

You must have set the keyboard mode either accidentally or on purpose, it isn't anything to do with your OS shortcut keys.
Tools > Options > General > Show advanced settings > Keyboard mode
If you want it to have normal Windows type shortcuts then it needs to be in Default not Emacs

The shortcut key issue has been solved, and above this is another problem. :pray: :pray: :pray:
Previously available. I opened it with vs code. I opened it with vs code.

I don't think that would be down to your settings file? I think those buttons just use the default editor set for .json files on your OS.

I tried the portable joplin today, and I found that the portable version can be opened by double-clicking it, but the installation version still doesn't work.
To prevent a problem with the css file, I tried to replace the installation version of the css file with the default, but it didn't work.
Ask for help.
I created a new topic.