Crashing on Android


I just tried to upgrade to -v1.0.151, but it crashes as soon as I open the app. I had to roll back to prev version which has no crash issue.

Does anyone have the same issue?

Sorry I was not able to get logs because I need to use it, but if this is only happening on my device I will try getting adb log


I could installed it but get 1n error that stuck the Sync

I have the same thing. It crashes when trying to open the V.1.0.151 of the app. I'm on adroid 7.0 and installed it via IzzyOnDroid's f-droid repository.

After reading your post I tried to install the previous version, 1.0.143, and that works fine.

It was the first time i'm trying this app so thanks for your post otherwise I wouldn't have persevered and just given up right away :slight_smile:

V.1.0.151 keeps crashing on my phone as well after installation. Galaxy Note 9 Android 8.1. I have rebooted the phone twice but the problem still persists. Will have to downgrade.

Same to me. Android 7.1.

Yeah it looks like 1.0.151 is borked.

I’m looking into it and also posted a question about it on SO. By the way if any of you know something about this crash, please let me know.

This version has not been released to the Play Store so a possible fix for now is to uninstall the app and get it from the Play Store, or install the APK v143, but again you’ll need to uninstall first.

v174 should work - please give it a try.

how can we be sure the v174 is installed ?
i'm not sure the installation update the v143, the install of the apk open a windows and close it very quickly
i' check the version of joplin but dont know where/how :slight_smile:

@foxmask, it’s the version there:

yes I downloaded it from here , but I dont know if android installed it or not (as the install process was very short). this is why I posted my previous comment.

Hmm, yes install is quick from the apk file but if there was no error I guess it worked. Version number is missing at the moment and would indeed need to be added.

ok so, as I said earlier, it does not crashed at all for me (on Android 8), but I got “unknown field” error message
But as I was stucked I wiped my joplin installation and so now it’s syncing since then.

with version 174, i'm still stuck with my previous error :confused:
trying to roolback to v143

That’s annoying, it could mean that the db didn’t upgrade properly. Does it work if you downgrade for now?

Otherwise do you have any way to check the sqlite database on your phone? If you have access, the db would be in /data/user/0/net.cozic.joplin/databases/joplin.sqlite

Then you could check if this migration has been applied properly:

And whether the table_fields table has the new resources fields.

What was the version of 3 October ?
V143 is broken too.i downloaded 3 version. I will see

I’d expect it won’t work if you downgrade because the db itself is not going to be downgraded, in fact it should throw an error. I’ll try to replicate your error later and see if I can provide a fix in the next version.

I tried to find the database on the device to try to revert the dB changes but found nothing.

@foxmask, you’re probably not going to like this but I think the best solution is to uninstall and reinstall the app and resync. I’ve just tried upgrading v174 on a device that didn’t have the recent releases and it works fine.

I guess I’m using these “soft” releases to GitHub as a way to test the app on my own devices but I’ll avoid doing this in the future as I see quite a few people are relying on them. Maybe I’ll create a “joplin-beta” GitHub repo where I’ll releases these tests.

I did a wipe yes, before I read your answer, and now will wait release from the store. :+1: