Joplin App keeps crashing on /e/OS

Hi all,

I have the problem, that the Joplin keeps on crashing /e/OS (degoogled Android, see I’m able to install the app succesfully, but when I start the app, it just crashes (then tries again and after the second try it gives up). I have tried the Joplin version from F-Droid, Aurora, /e/ Appstore. They all have the same issue. Currently I have version 1.0.333 from the IzzyOnDroid repository installed.

In the /e/OS Forum ( users are able to use Joplin without any issue (indicating that there is no issue with this combination). I genuinly do not know where to post this issue first. I decided to start in the Joplin forum, as my logcat.txt (attached) indicates to me, that a Joplin developer might identify the issue easier. It could well be, that the issue then has to be solved on /e/OS side. Who knows.

logcat.txt (68.0 KB)

The /e/OS version I’m on is 0.9-2020062860623 (which is based on Android 7.1.2). Model is Samsung S7.

Thanks a lot in advance for any help! This is my final missing puzzle on this phone.


I see no Joplin-specific errors in the log, just missing classes and libraries but that’s a system issue.

Joplin uses a Google lib for notifications so I’m surprised it could work at all. Probably those who managed to make it work have either installed the Google library or something that emulates it.

Thanks for checking! The libraries in that case should come from microG (, which is used on /e/OS for those kind of libraries. Will open up an issue on the /e/OS side in that case.


/e/OS that’s an interesting Os.
I hope you will find a solution. If you have time for this, I think in the “Lounge” category some people would be curious to have your feedback about this OS.

I have found LineageOS is a good phone OS, especially for phones that would never receive further upgrades. Also if upon install you choose not to include the Google package you get a “de-googled” phone. I used an old WileyFox Swift (which is now on LineageOS 17.1 - Android 10). It doesn’t have any Google services installed and it runs Joplin quite happily using the apk downloaded from the Joplin web-site.

Thx. That is something I did not try yet. However, have downloaded it from the Joplin website now, but issue remains the same.