Can't change options

I started using joplin ver.1.0.179 in windows system several weeks ago, and everthing was great. But when I recieved an upgrade suggetion and install joplin ver.1.0.193, I just can’t enter the options interface anymore. When I click Tools/Options, I will get a blank interface without any options I can change in old version. What’s more hopeless is I can’t install back old version… I tried other version such as 189,192, but problem still exist.

I really like this software, but what should I do to solve this problem?

@youli-jlu Welcome to the forum

I notice that this post has been here without any replies for a couple of days now. Have you solved this yet or has it resolved itself?

EDIT: If it is still not working, what version of Joplin are you using (full install or portable) and what version of Windows?

Thank you for your reply!

This problem still exist. Every joplin I installed were full install, not portable version. And my system is windows 10 family version.

Recently, I found that I can’t click ‘synchronise’ in sidebar, too. Nothing would happen when I click it.

I have not had this problem and I do not know what is causing it but this is how I would likely tackle it.

This assumes that there is something wrong with your Joplin install rather than a problem with your OS. This may not be the case. It is a “destroy with fire” approach, so rather than go ahead with this straight away you may possibly wish to wait and see if there are any other (better) suggestions. This is not a proven solution, just something you could try.

  • Make a JEX backup / export of your notes and store it somewhere safe (File > Export > JEX - Joplin Export File).
  • If you use End To End Encryption (E2EE) make sure you know / have a copy of the password.
  • QUIT Joplin (File > Quit)
  • If you have created any, copy elsewhere any custom template files and / or css files found in C:\Users\<username>\.config\joplin-desktop - Where <username> is your account name on Windows
  • On Windows uninstall Joplin using the Windows uninstaller
  • Delete these (if still present)
    • C:\Users\<username>\.config\joplin-desktop
    • C:\Users\<username>\AppData\Roaming\Joplin
    • C:\Users\<username>\AppData\Local\joplin-updater
    • C:\Users\<username>\AppData\Local\Programs\Joplin
  • Restart Windows just for the sake of it
  • Install the latest release version of Joplin
  • Check if you can get to the Tools / Options screen
  • If yes
    • Connect the client to your cloud storage and let it sync (hopefully)
  • If no
    • Come back here and get some better advice!
1 Like

You suggestion works! Thanks again!

I think this problem may occur when you choose different user option in high-version installer.

Whatever, I can enjoy joplin again!

That's the most important thing! :slightly_smiling_face:

@dpoulton nice one, if there was a troubleshooting on Windows FAQ, then your instructions should be on it.

Do you remember which options you chose? and how was it different?

I may choose install for myself in version.1.0.179 and install for all user in version.1.0.193.

I’m not sure if this cause my problem, but I did find two default directory when I use dpoulton’s method. They are C:\Program Files\Joplin and C:\Users<my user name>\AppData\Local\Programs\Joplin .