Can't access main menu on Joplin GNU/Linux

How do I get back the Joplin main menu bar or access the main menu? I can't export all notes, access the settings, or check the version to report a bug, or anything else. I only get a window menu with options "New window, Quit". I've checked the gnome settings, checked if any joplin key shortcut could help, searched in this forum, on google.. I can't find any way to get the menu back and I need to export all my notebooks at once. I'm using Joplin on ubuntu 20.04
Please halp! I don't know what else to try - Thanks in advance!

Same issue here, nothing useful to add yet, but if I manage to get any logs or anything out of it I'll post them here.
I'm running Kubuntu 21.04

The issue does not appear specific to the Snap package, after removing the snap package and installing the app using the Install script, I still have the same issue.
The only error that I can find is the following:

Gtk-Message: 18:10:17.495: Failed to load module "window-decorations-gtk-module"
Gtk-Message: 18:10:17.495: Failed to load module "colorreload-gtk-module"
Gtk-Message: 18:10:17.495: Failed to load module "appmenu-gtk-module"

(joplin:38248): dbind-WARNING **: 18:10:17.528: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-LJbMEZ7jtj: No such file or directory
/usr/share/libdrm/amdgpu.ids: No such file or directory

My hardware:
CPU: Ryzen 5 3600
GPU: Radeon RX 6900 XT

My software:
Kubuntu (Ubuntu with KDE Plasma) 21.04
Joplin-desktop snap v2.3.5 (as mentioned above, I also tried installed joplin directly)

I should also note, this issue could have coincided with any of following three things, which all happened in a short period of time:
1: Updating joplin (I did rollback and the issue persisted, so I don't think this caused it.)
2: I purchased a new GPU to replace my previous NVidia GT1030
3: I upgraded from Kubuntu 20.04.2 (LTS) to Kubuntu 21.04

If there is any other info I can provide that will help with troubleshooting, please let me know.

Further update (including my solution):
In my case, it turns out this was due to changed default behaviour in KDE Plasma.
The solution that worked for me was the following:

From the Application Dashboard/Launcher/Menu, select "Settings" (in the Launcher: under "Applications") → "System Settings" → "Application Style" → "Window Decorations" → "Titlebar Buttons"; then drag and drop the "Application menu" icon to the titlebar.

Source: Unix Stack Exchange, the forum won't me include a link for some reason, but the question title is "KDE global menu disappeared in Plasma 5.12" (question number 425168).

Hopefully this helps someone else.

Thank you :slight_smile: Unfortunately I cannot seem to find a way to fix this on gnome :confused: I've tried searching among the "gnome tweaks" settings and the system settings, and installing appmenu-gtk3-module, nothing so far.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.