Cannot syncronize on Android 10. "Attempt to get length of null array" error

Joplin 1.3.13, database v34
LG G8 Thinq, Android 10 G820TM20e

I have a Joplin notebook on my Win10 PC that I'm trying to sync to my phone. I use Syncthing to copy the folder across devices. I just switched phones today and now I can't sync on the new phone in Joplin. It was working previously on my Moto G6 running Android 9.

So what I do is sync my notebook on my PC to a local directory using the "File system" option. Then I connect Syncthing between the PC and phone and point to said director. That all works fine and now I have all the .md files on both devices. Then I try to sync Joplin on my phone and I get an error:

Could not read directory: /storage/emulated/0/1 Syncthing Share/Joplin Notebooks/locks: Attempt to get length of null array. Path: /storage/emulated/0/1 Syncthing Share/Joplin Notebooks/locks

I've granted all three permissions Joplin asks for. I'm not sure what could be causing this. My debug report is attached.

syncReport-1604944165079.txt (51.7 KB)

1 Like

I'm also having this problem. The Locks folder is empty on my computer and adding a blank text document didn't help.

I tried re-installing the app to get whatever should be in the Locks folder, but it didn't even create the directory structure, let alone populate it.

I have the same problem. Lock folder is empty on my computer.

I use the Windows 10 version of Joplin and use the file synchronization to a local directory that is subsequently copied to my QNAP storage platform (Using their Qsync app). My Android phone also uses Qsync to pull the latest copy into a local directory which I am attempting to file-sync via the Android Joplin app. This results in the same error message that others have shared here.

I am also having the same issue syncing my notes from my Mac to my Android using Syncthing. The locks folder exists on the Android, and is empty (as on the Mac).

Same error message as the others.

I have the exact same problem, here is the informaton I could gather, also this is somewhat related, good luck managing the permissions.

I could not resolve the issue. I was able to setup a webdav server on my NAS box and now use that to sync Joplin between handheld and desktop without using public cloud.

I have this problem also. It is not the first time. I found a while ago a post online that said to use a different version and I did and it worked....but then it auto updated and I cant remember what i did. I tried old versions, new versions and pre-release versions. No luck yet. if i find a solution i will post.

so i uninstalled the current version, 1.5.x and then tried starting with 1.3.10, 1.3.11, 1.3.13, 1.4.6, 1.4.11 and none of them worked. i installed the 1.6.4 and all of a is syncing. hopefully that version sticks around and works. it is a pre-release so i dont know what that might bring to the table but syncing is a good thing.