Cannot synchronize my notes on my Android 12 Phone

Hi to all,

I cannot synchronise my notes on my new phone. Or, more precisely, the synchronisation seems to run well. But the notes from the server do not appear.


  • Joplin 2.9.17 On Mac OS X 13.3.1 Ventura
  • Joplin 2.10.8 on Samsung S10e with Android 12
  • A webdav server powered by NextCloud

This new phone replaces a previous one, same model, same OS. Joplin synchronisation worked perfectly on the old one.

What happens

Joplin on Mac and Android synchronises by webdav (the server is powered by NextCloud). On the server, .md files and lock and temp directories are present.

Joplin on the new phone says that the synchronisation configuration "seems correct". I don't use data encryption. I've given all authorisations to Joplin: files, location, photos.

When I synchronise, I see that some work is done. Joplin tells that local objects are created and/or downloaded.

But the notes from the server are not displayed. No new Notebook appears.

Each time I synchronise, Joplin announces the creation of a few hundreds of objects.I have about 760 notes. And there are 3800 files in the App/Joplin directory.

The five notes in Welcome! (Mobile) are successfully send to the server and to the Mac.

Any hints to get my notes on my Android ?

Thanks in advance,


I think your initial sync is not finished.

Joplin does not have a background sync on mobile devices. When Joplin is closed, sent to the background or the device is put into sleep (display off), the sync is interrupted.

The fact that the sync was not finished was my first guess.

But I've tried to synchronize several tenth of times since yesterday evening. Without closing Joplin, and sometime preventing the phone to go to sleep. Most of the time the sync ends with a Cancel phase which lasts several minutes. Number of created local itemsand Fetched items may increase during the cancel phase (??)

I will insist on trying and waiting, but it's a bit tedious ...


This morning, I have One (1) note that has arrived on the phone.

I finally make a force synchronization from the server to the mac, after removing all locks and temp files on the server. Then I've reinstalled Joplin on the phone, and the synchronisation went smoothly in a few minutes.

I first tried a forced synchronization from to the mac to the server, but it didn't change anything.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.