Taking days (or more) to sync on android


  • Joplin on android 2.10.8
  • Filesystem sync

It's been several days since I set up Joplin on my new android phone and every time I go into Joplin it is synching again. Every time I check in, it's not done synching. Actually I think it's about week now and it seems to synch some notes every time. I have some notes in there that are synched, but still no notebooks.

I came across this article Sync issues finally drove me away from the Joplin note-taking app | Ctrl blog a few days ago which describes pretty much the case I'm seeing. Is there some reasonable way to work around this aside from installing an older version and using that to sync?

github issue: takes hours for android sync from filesystem to complete · Issue #8123 · laurent22/joplin · GitHub

You need to leave your device on until it's fully synced. Just plug it and leave it on over night

While I experienced syncing issue, it was only temporary until I restarted the app. I use AWS S3 for syncing. It is currently in beta, but works well across my devices so far. Probably, you could try other options for syncing such as AWS S3.

As for the article, I read it too (I follow his blog). There is no perfect note taking app. Of course, syncing is a basic feature.

@laurent it still didn't complete. you can see the result here. 5 hours and 29 seconds, and still no notebooks. I think also the app will close then the phone goes to sleep sometimes?

You need to make sure the phone is awake during the sync, there are some apps that will do that like caffeine.

I filed a ticket here because given how fast it used to sync, something's wrong

You need to provide the log then, because there's probably an error somewhere

I don't see anything in the logs. Can I enable more logging?

Also, I recently had another phone which had the same issue, and I did roll back at that time to get the notes quicker. This is not an isolated experience

What do you use for sync? SyncThings?


FYI, I gave up waiting, rolled back to 2.4.3 and got it all synced in 30 minutes. i noticed that when I used 2.4.3 and then upgraded, I got errors about file locks, and I had to run the adb commands which were an issue for a long time. I'm wondering if that had something to do with it

another side-effect now is that the icons didn't get synced to the phone this time. that seemed intermittent even before

We recently updated the filesystem api so that could be the reason. We had to because it was required by Google

I use DropBox for syncing, and it works acceptably for me. Syncs from my Android phone or my Windows and Linux computers in seconds, not days.

how many notes do you have? I have 2193 notes taking 887 MB

I would expect that if I just had a couple of notes, it would take seconds too

You're correct, I only have only about a dozen text notes, with nowhere near that volume.

Mine originally took almost 3 days for the first time to my Android (macos and windows were a lot faster). Since the initial sync it's at a normal speed.

I have to agree with @joeschmoe . Sync on my Android phone is abysmal. I've done the initial sync but each sync every time I open Joplin takes soooo long. There may be 10 notes or changes. Sync to Dropbox used to happen almost immediately. Even cancelling the sync on Android takes for ever and seems to time out.

I have about 2000 notes taking up 625MB. Sync to Dropbox on the Mac is seconds. Sync with Android took only a few seconds more. Now on Android 13 phone the sync times out and Android says that Joplin is using too much battery/power and should be optimized.

I'm on Android 13 with Joplin version 2.10.8 syncing to Dropbox.
It used to work fast, but I just noticed on my desktop that I'm not getting the changes from my phone. Then I realised there is an issue now with the syncing.
I click on 'Cancel' and it just keeps going with the message: Cancelling... and does not complete.
It doesn't matter if I restart the app, it's the same behaviour.
The desktop app has no problem syncing to Dropbox.
Happy to provide logs if that helps?

1 Like

Okay, I sorted my issue by logging into Dropbox and finding there was a lock file - which I later discovered was the issue - stopping my Android app from syncing.
So I deleted this lock file, then activated the Android app and it once again successfully synced my changes. I then did a sync with the Linux desktop client and all the Android changes came through successfully.

1 Like

Hi Pieterv thanks for the note. I'm facing the same issue, using Dropbox:

I click on 'Cancel' and it just keeps going with the message: Cancelling... and does not complete.

Do you remember where the lock file was, in Dropbox?
In Apps > Joplin, I got folders .lock and locks, and worry about just deleting stuff in there.

Joplin should give more info if there's a locking problem.