Homepage    |    GitHub    |    API    |    FAQ

Cannot download all images on Android over WebDAV sync

I've synced up my notes over synology webdav (can't use docker because my nas does not use an intel chip). On all my desktops (mac os), images sync fine. but for some reason the android app just simply doesn't want to download ALL resources. I've tried "always", "automatic", "manual". I've trying clearing cache, clearing data. I even tried reinstalling. There was this one time it managed to download several thousand, but i had to painstakingly continuously fiddle around with the attachment download behavior it would download like a couple hundred, then a couple like tens etc. and eventually just stopped downloading when it got to like 3000. I have more than 10,000 images. Even if I wanna load each image individually within a note, when i click on the little download icon on an image it doesn't do anything. So bottom line I really can't get ALL images to display. ideally what i'd like to do is to be able to just transfer everything over usb since it's over 1GB of images directly to the resources folder, but it's buried in /data/data/ which i don't have access to because i'm not rooted. I see only one or two posts on this issue, so maybe there's something wrong with my android version. I'm running the latest OTA update on a Galaxy Note 9 if that helps.