Can we use less mouse when entering tags

I prefer keyboard shortcuts when entering texts.

When I need to add tags to a note, I use CTRL +t, which opens the tag window with the cursor ready.

Next I type for the tag I desire and hit "Enter" to select the active tag, and continue typing to add another tag.

When I've added the final tag, I should be able (IMO) to hit "Enter" which is the equal of clicking OK... but that does nothing (I'm nearly sure it used to close the window, saving the selected tags).

BUT... there is no obvious means to trigger "OK" without reaching for the mouse. I've tried tabbing, or using the space bar, but nada.... Can this be made more keyboard friendly? My natural tendency is to simple hit "Enter" to finalize tagging. I'd love to see that. Thanks!

Consider this plugin to add tags on the fly, while typing text.

1 Like

I am not getting this problem. I use Joplin 2.9.17 on Kubuntu 22.04. After using "Enter" to confirm or create the last tag, if I press "Enter" again it closes the tag dialog and saves the tags I have selected / created.

This is exacly what I need.

I'm running Win 10 and Win 11


Joplin 2.10.3 (prod, win32)

Client ID: f97xxxxxxxxxxxxxx
Sync Version: 3
Profile Version: 41
Keychain Supported: Yes

Revision: 7a0af66


Earlier versions would not allow selection of existing tags with "Enter". That part has been solved, But still "saving" the tags with "Enter" is broken.

I see what you mean. I just installed 2.10.4 (default install - no plugins) on both Win 10 (22H2) and Win11 (21H2) and the final "Enter" to save and close the dialog does not work.

Is there a reason you have to have a 2.10.x pre-release?

I ask as I also installed the latest actual release version (2.9.17) on both the above Windows OSs and the enter key selects existing tags, creates new tags, and saves the tags / closes the dialog box as you want it to. No mouse required.

I have not searched but if it has not already reported it may be worth raising an issue on GitHub or maybe posting in the Beta Testing section of this forum that the 2.10.x versions break this existing functionality.

1 Like

Just for bug/security fixes... No particular reason

I rolled back both installations and all works as you described.

I'll link this thread to the beta section here.... Thanks!