Bug saving notes in external editor

i adore joplin and its many (and sufficient!) features. escpecially i like the possibility of editing notes in the external editor. however, i found out only recently about a major bug when it comes to saving notes in the external editor. which caused the loss of data of a full day writing… :-&

the bug is the following: i edit the a note in the external editor and when i push the “save” button in my external editor (in my case gedit), then it updates/synchronizes the note correctly with the note within joplin. BUT if i keep on writing and keep on pushing the “save” button (which i do very frequently when i write important stuff!) it does not continue to syncronize the text with joplin. so for instance i start writing the note and push the “save” button the first time after 5 minutes and go on writing all day, then at the end of the day i find only the writing of the first 5 minutes and the rest is gone!!! there is no difference whether i close the external editor directly or i close it from within joplin.

here are the specifications of my system: i run a joplin client on debian stretch and use gedit as my external editor.

anyone else experienced the same problem?

1 Like

Unfortunately it seems there’s a bug with external editing in Linux https://github.com/laurent22/joplin/issues/1614

oh i see…

This issue also exists with gvim, but it’s fixable by changing some settings in vim see this forum post I bet theres something that can be changed on the gedit side to get this to work. I’ll look into it.

edit: I did some digging and this appears to be a chokidar issue it’s closed but in the referenced pull request it looks like it should be re-opened.

I couldn’t find a setting you could use for gedit, but I found a fix on the Joplin side. You can track the change here

1 Like

@CalebJohn, thanks for taking care of this issue. however, i could not follow the fix you suggest on github. which file do i have to modify so that this issue doens’t occur anymore?

1 Like

Hi @kore, my mistake I had a typo in my previous message. I could not find a fix that worked on your end. All you can do (to the best of my knowledge) is wait for my change to get merged and then update to the new version of Joplin. Alternatively you could switch editors for a bit

sure. would be great if you update here, if it’s fixed in a future version of joplin!

Last few releases haven’t been too far apart (7 and 11 days) so hope this gets merged and released soon (pending Laurent’s testing on Windows to make sure it doesn’t break anything).

Merged! Should be in the next release https://github.com/laurent22/joplin/pull/1659

I’m having the same problem that @kore described. The recent fix (#1659) doesn’t correct the problem.
For my external editor, I’m using xed on Linux Mint 19.1, Cinnamon 4.0.10. I had the same issue with Sublime Text, but it seems to be fixed now.

The sequence I followed with xed was:

  1. Click the Joplin icon to start the external editor (Icon says “Watching…”)
  2. Make some changes to the note and save them without closing xed. (Changes appear in Joplin, icon still says “Watching…”)
  3. Make more changes to the note and save them without closing xed… (Changes don’t appear in Joplin, icon still says “Watching…”)
  4. Click the “Watching…” icon to turn it off and then click the icon again to start the external editor. (xed, which is still running, notes that the file has been changed by another process and offers to reload it.)
  5. Do not reload the file. Save the file again. (xed warns that other changes made to the file will be lost.)
  6. Save the file in xed. (Changes appear in Joplin, icon says “Watching…”)

Thats unfortunate, as I suggested earlier in the thread perhaps you could find a xed specific fix? This is a complex upstream bug and it would likely be a time sink. Sorry.

i just did the update on version 1.0.170 in the hope that the bug is fixed meanwhile. i still would love to work with my preferred text editor gedit. but the bug seems not to be fixed also in the latest version. it doesn’t seem to be a xed specific problem…

update: i was mistaken, the editor is being watched perfectly as long as the changes are saved. so the bug seems to have been fixed.

I am having this exact problem (after many saves from external editor, changes stop appearing in Joplin) with Joplin Desktop 1.0.227. I have tried gedit and pluma, and both have this issue.

Ok, using gedit and adding --new-window to the arguments field seems to have solved my problem.

Never mind. This bug is just intermittent.

I still have this error with gvim as external editor.

Since upgrading to the new version this is broken.

  1. When I edit files and save, the new text is not reflected in Joplin (but after save + close it appears)
  2. When I go on writing after I saved the first time, everything since the first write is lost.

I tried this with both Windows / Linux and Versions 1.2.6 and 1.3.9

Additionally, after creating situation 2 (writing on after saving) on Linux, the Joplin App crashes and I have to kill it.

I have this with marktext