Homepage    |    GitHub    |    API    |    FAQ

Blank Screen on start up in Windows 8.1

I'm new. Thought I'd try Joplin. I loaded Joplin 1.7.10 on an old Mac and everything seems fine. I loaded 1.7.11 onto a little traveling ASUS laptop running Windows 8.1 and it only shows a blank screen on start up. I loaded an earlier version and get the same result. I get the following from the Console tab of the Developer Tools. … Well I cut it off because it was really long but will gladly provide the whole thing … Thank you for any fix.

from the Console tab:

internal/modules/cjs/loader.js:961 Uncaught Error: Cannot find module 'C:\Program Files\Joplin\resources\app.asar\node_modules@joplin\lib\node_modules\sqlite3\lib\binding\napi-v3-win32-ia32\node_sqlite3.node'
Require stack:

  • C:\Program Files\Joplin\resources\app.asar\node_modules@joplin\lib\node_modules\sqlite3\lib\sqlite3-binding.js
  • C:\Program Files\Joplin\resources\app.asar\node_modules@joplin\lib\node_modules\sqlite3\lib\sqlite3.js
  • C:\Program Files\Joplin\resources\app.asar\node_modules@joplin\lib\database-driver-node.js
  • C:\Program Files\Joplin\resources\app.asar\node_modules@joplin\lib\BaseApplication.js
  • C:\Program Files\Joplin\resources\app.asar\app.js
  • C:\Program Files\Joplin\resources\app.asar\index.html
    at Module._resolveFilename (internal/modules/cjs/loader.js:961)
    at Function.i._resolveFilename (electron/js2c/renderer_init.js:39)
    at Module._load (internal/modules/cjs/loader.js:844)
    at Function.Module._load (electron/js2c/asar.js:769)
    at Module.require (internal/modules/cjs/loader.js:1023)
    at require (internal/modules/cjs/helpers.js:77)

Is your OS 32 or 64 bit? Looks similar to White window Windows 10 · Issue #4361 · laurent22/joplin · GitHub
Can you also try the portable version? It works for me on Win 8.1 x64

32 bit OS. x64-based processor. Tiny ASUS laptop if that matters. Thx

As suggested in the issue I linked, can you try a few different versions (probably easier with portable) to see which version is the first that has this issue?

I plan to try the portable version. Hope it works. Thx. Guess I’ll give some old ones a chance if it doesn’t. Thx some more.

from phone

Tried currently linked version of portable Joplin with same results. It won't shut down either - have use Task Manager to shut it down. Oh well. I'll try a couple more times with some older portable Joplins if I can find them. Thx for the suggestions.

You can find older versions here: Releases · laurent22/joplin · GitHub

Snagged an older portable version, 1.1.1, and it seems to be working on this old Windows 8.1 ASUS laptop. Thx for suggestions and time.

No problem.
If you have time, can you try a few other versions in between? Would be good to understand where it broke.