Joplin-2.14.21 serious bug

Operating system

macOS

Joplin version

2.14.21

Desktop version info

Version 2.14.21 (2.14.21)

What issue do you have?

Hi, I just got prompted to update to Joplin-2.14.21 which I just did. The prior version (I always update as soon as notified) worked just fine. 2.14.21 is completely unresponsive.

When I launch Joplin it's very slow and just hangs. The main Joplin window displays eventually but there is no data or content visible. See attached screenshot.

Desktop version of Joplin. Apple Silicon M1 Macbook Pro. Sonoma v 14.6.

Screenshots

Could you please confirm which file you downloaded? Was it " Joplin-2.14.21-arm64.DMG "?

Edit: it works for me on Macbook with Intel processor

I downloaded the file that Joplin automatically prompted me to download. It is titled:

Joplin-2.14.21.dmg

UPDATE:

I just manually downloaded "Joplin-2.14.20-arm64.DMG" reinstalled it (I had to reset the master password) and I seem to be up and running again. It appears to be functioning normally.

It appears Joplin may have erroneously prompted me to download the Intel version. I just assumed it was appropriate.

2 Likes

I'm also getting an error with Joplin 2.14.21 on MacOS Sonoma (x86_64):

node:internal/modules/cjs/loader:1087 Uncaught Error: Cannot find module '/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/sqlite3/lib/binding/napi-v6-darwin-unknown-x64/node_sqlite3.node'
Require stack:
- /Applications/Joplin.app/Contents/Resources/app.asar/node_modules/sqlite3/lib/sqlite3-binding.js
- /Applications/Joplin.app/Contents/Resources/app.asar/node_modules/sqlite3/lib/sqlite3.js
- /Applications/Joplin.app/Contents/Resources/app.asar/index.html
    at node:internal/modules/cjs/loader:1084:15
    at Function._resolveFilename (node:electron/js2c/renderer_init:2:3225)
    at node:internal/modules/cjs/loader:929:27
    at Function.<anonymous> (node:electron/js2c/asar_bundle:2:13327)
    at Function._load (node:electron/js2c/renderer_init:2:2455)
    at Module.require (node:internal/modules/cjs/loader:1150:19)
    at require (node:internal/modules/cjs/helpers:110:18)
    at Object.<anonymous> (/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/sqlite3/lib/sqlite3-binding.js:4:17)
    at Object.<anonymous> (/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/sqlite3/lib/sqlite3-binding.js:7:3)
    at Module._compile (node:internal/modules/cjs/loader:1271:14)

Edit: ~~Could this be related to Chore: Fix nan · laurent22/joplin@00d0cd1 · GitHub
Edit 2: It seems that the ARM64 version of SQLite is included in Joplin-2.14.21.dmg:

> fs.readdirSync('/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/sqlite3/lib/binding/')
['napi-v6-darwin-unknown-arm64']

Same error here. Downloaded latest as prompted this morning. Macbook Air Intel, macOS 14.4.1 (23E224). Tried to find older downloads, no luck.

Update: restored to 2.14.17 via Time Machine, working fine.

Based on the build log, I think we're experiencing this issue:

The workflow being used to build the x86 version of MacOS Joplin in CI runs on macos-latest, which seems to now be ARM64.

Edit: Pull request:

Same problem here as well, also used Time Machine to roll back successfully to Joplin 2.14.20 (prod, darwin)

Client ID: 49827ee4b66f4367a34c0f46ea1db6d3
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: cfd98e3

Backup: 1.4.0
Favorites: 1.3.2

Running macOS 12.7.5, Mac mini (2018), 3.2 GHz 6-Core Intel Core i7

Same issue on Macbook Pro M1, macOS 14.5

On the Joplin website, the macOS M1 link still points to 2.14.20.

You can manually download and install the latest version using this link, which fixed the issue for me:
https://objects.joplinusercontent.com/v2.14.21/Joplin-2.14.21-arm64.DMG

1 Like

DO NOT DOWNLOAD v2-14.21!!! It will totally wipe out all your files and you'll just get a blank white page. It will not quit. You will have to force-quit twice. Fortunately, I had backed it up on Time Machine just a couple days ago so I was able to reinstall v2.14.20. I'm not trying anything else until I'm sure this bug has been fixed.

MacBook Air, M2, 2023, Sonoma 14.5

Thanks for the Workaround! It helped me instantly.

1 Like

Same problem on MacOS High Sierra (Intel). The app just shows a white screen. I reverted to v2.14.20 because I still had the .dmg file, and now it works again.

Same problem on iMac with OS Catalina (10.15.7) with 3.5 GHz Quad-Core Intel Core i7.

I also did what bigern77 did. I had the "2.14.20.dmg" file. Always keep the previous version in your computer.

If you have downloaded this release please revert to the older one:

1 Like

Thank you.

I also had the problem with 2.14.21 on Ventura 13.3.1(a) / Quad Core i5. I'm providing a screenshot of the error message in case the additional detail is helpful: