Automatic updates not working on Linux

I’m running version 1.0.179 on Linux Mint 19.3.

I’ve checked the automatic updates checkbox, but alas I get no updates, and no update notifications either. This recently led to a bit of a faff where notes from Android wouldn’t be decrypted. Am I doing something wrong?

The install and update script didn’t work from updating to 1.0.195 either - I had to update manually for some reason.

All is working now I’ve updated, but I thought it was worth mentioning.

This was an issue with 179 for all platforms that was fixed in a later release. Version 193 onwards has a new encryption method, meaning that updating the Android app could have broken encryption methods for older desktop clients and you should go to Tools=>Options=>Encryption and click Re-encrypt Data if you haven’t already.

There are quite a few posts here about all of this. :wink:

Yeah, the encryption is now being sorted :slight_smile:

The problem was that I didn't know there was an update, because I didn't get notified.

1 Like

Hi I’m try to track down that second bug you experienced (install script not running). If I may ask, what is the output of running uname -a in your terminal?

uname -a returns:

Linux Ryzen-PC 5.3.0-42-generic #34~18.04.1-Ubuntu SMP Fri Feb 28 13:42:26 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Thanks! Looks like that isn’t causing the problem, which is good!

1 Like

Good to know.

1 Like

Could you try the below command and send me the output?

wget -O - https://raw.githubusercontent.com/CalebJohn/joplin/arch-check/Joplin_install_and_update.sh | bash

I’ve made some debug modifications to the script. I’m not able to reliably reproduce this issue.

--2020-03-27 21:12:41--  https://raw.githubusercontent.com/CalebJohn/joplin/arch-check/Joplin_install_and_update.sh
Resolving ...... 199.232.56.133
Connecting to <> (<>)|199.232.56.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5579 (5.4K) [text/plain]
Saving to: ‘STDOUT’

-                     0%[                    ]       0  --.-KB/s                    _             _ _       
    | | ___  _ __ | (_)_ __  
 _  | |/ _ \| '_ \| | | '_ \ 
| |_| | (_) | |_) | | | | | |
 \___/ \___/| .__/|_|_|_| |_|
            |_|

Linux Installer and Updater
0
0
0
-                   100%[===================>]   5.45K  --.-KB/s    in 0.1s    

2020-03-27 21:12:46 (45.8 KB/s) - written to stdout [5579/5579]

Links removed because I’m not allowed more than 4.

Did it succeed? it looks like it might have downloaded

I think they changed something to the AppImage format so the grep call is failing, but since it’s after a pipe the error is not printed. However since the script has “set -e”, it is stopped immediately.

There’s an open PR that fixes the grep call.

1 Like

@CalebJohn

I do not know if @laurent 's post above means that this is no longer required but, regardless, this is a failed one.

uname -a
Linux linuxmint193-vm 5.3.0-42-generic #34~18.04.1-Ubuntu SMP Fri Feb 28 13:42:26 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Output

vbox@limuxmint193-vm:~$ wget -O - https://raw.githubusercontent.com/CalebJohn/joplin/arch-check/Joplin_install_and_update.sh | bash
--2020-03-27 23:52:11--  https://raw.githubusercontent.com/CalebJohn/joplin/arch-check/Joplin_install_and_update.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.0.133, 151.101.192.133, 151.101.128.133, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.0.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5579 (5.4K) [text/plain]
Saving to: ‘STDOUT’

-                   100%[===================>]   5.45K  --.-KB/s    in 0s      

2020-03-27 23:52:11 (27.4 MB/s) - written to stdout [5579/5579]

     _             _ _       
    | | ___  _ __ | (_)_ __  
 _  | |/ _ \| '_ \| | | '_ \ 
| |_| | (_) | |_) | | | | | |
 \___/ \___/| .__/|_|_|_| |_|
            |_|

Linux Installer and Updater
0
0
0
vbox@limuxmint193-vm:~$ 

Thank you @dpoulton! This is helpful! It basically confirms what @laurent says above, the failure is happening in the grep call for getting the release version. There’s already a pull request to fix it so we should be in good shape.

1 Like

404: Not Found

Joplin 1.3.18 (prod, linux)

Client ID: 7622986f03a94dae97d86d94f0f1a0ae
Sync Version: 2
Profile Version: 34
Keychain Supported: No

Revision: 6b75485 (master)

uname -a
Linux HAL9000 5.4.0-58-generic #64-Ubuntu SMP Wed Dec 9 08:16:25 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

wget -O - https://raw.githubusercontent.com/CalebJohn/joplin/arch-check/Joplin_install_and_update.sh | bash
--2020-12-17 20:01:46-- https://raw.githubusercontent.com/CalebJohn/joplin/arch-check/Joplin_install_and_update.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.0.133, 151.101.128.133, 151.101.64.133, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.0.133|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2020-12-17 20:01:46 ERROR 404: Not Found.

Hi @lambu

The code that I posted above was only to help debugging the original issue. It has been fixed and I removed that debug script. 404 is the expected result because the file no longer exists.

1 Like

Thank you Sir.
So updating is running smooth in my case?Screenshot from 2020-12-17 22-08-57

Sry for beiing stupid, i am new Bee with the desktop App

No worries, not stupid, auto updating isn't supported on linux so you'll need to use the below command to update.
The automatic update option was accidentally made available on linux platforms (even though it doesn't work). It's removed now which should help with any confusion.

wget -O - https://raw.githubusercontent.com/laurent22/joplin/dev/Joplin_install_and_update.sh | bash
1 Like

| | ___  _ __ | (_)_ __  

_ | |/ _ | '_ | | | '_ \
| || | () | |) | | | | | |
_/ _/| .__/|
||| ||
|
|

Linux Installer and Updater

Checking architecture...
The latest version is 1.4.19, but you have 1.3.18 installed.
Downloading Joplin...
/tmp/tmp.Lj7bX6xwDC/Joplin.AppImage 100%[=====================================================================================================>] 139,02M 991KB/s in 2m 23s
/tmp/tmp.Lj7bX6xwDC/joplin.png 100%[=====================================================================================================>] 22,45K --.-KB/s in 0,02s
Installing Joplin...
OK
Installing icon...
OK
Create Desktop icon...
grep: /tmp/tmp.Lj7bX6xwDC/squashfs-root/joplin.desktop: No such file or directory
OK
Joplin version 1.4.19 installed.
Cleaning up...
OK

Thank you
sometimes its very comfortable to be stupid
but if not u are in trouble

1 Like

Thanks for letting me know this is fixed, I completely forgot about this issue and apparently wasn't notified. Marking as solved.