Anyone else have a grey vertical bar at left edge of the MD editor?

Operating system


Application version


Desktop: About dialog content

Joplin 2.13.5 (prod, win32)

Client ID: 75c3f61fd5bd4b80b2b8a135d6cc0c16
Sync Version: 3
Profile Version: 44
Keychain Supported: Yes

Revision: 1d04ec6

Automatic Backlinks to note: 3.0.3
Conflict Resolution: 1.2.3
Convert Text To New Note: 1.5.1
Favorites: 1.3.0
Folding in Code Mirror Editor: 2.0.1
Hotfolder: 1.1.0
Inline tags: 1.2.1
Inline TODO: 1.7.0
Insert Date: 1.0.1
JSheets: 1.1.3
Link Graph UI: 1.5.0
macOS theme: 1.3.13
Markdown Table: Sortable: 1.2.2
Note overview: 1.6.0
Note Tabs: 1.4.0
Outline: 1.5.10
Quick Links: 1.2.4
Rich Markdown: 0.13.3
Simple Backup: 1.3.3
Table Formatter Plugin: 1.2.1


Markdown Editor

What issue do you have?

I had previously posted on what I now believe is a related issue here: No cursor on empty rows / lines in markdown editor

And I was experiencing that with Joplin 2.12.19 (prod, win32), so it's not specific to the latest beta, which I'm on now.

I disabled any custom css, and still experience this issue. It seems this grey bar 'hides', or makes not visible the cursor, when the cursor is at the left edge of the editor pane (the cursor behaves normally, it's just not visible when at that left edge).


Have you tried disabling the macOS theme and the Rich Markdown plugin? Just as a test?

Can you find out anything by going to Help>Toggle development tools and then inspecting that area?

1 Like

Good idea.

Rich Markdown and macOS theme plugins disabled: grey bar goes away, invisible cursor at left edge remains

Rich Markdown disabled: grey bar persists, invisible cursor at left edge remains

macOS disabled: grey bar goes away, invisible cursor at left edge remains

So it looks like the grey bar is related to macOS plugin, and NOT related to the invisible cursor at left edge. So perhaps I should mark this grey bar issue as resolved and focus on the invisible cursor issue.

1 Like

It looks like a gutter from Folding in Code mirror.
30% of posts in its thread are complaining about that so

Persistent text folding in editor

It's strange that it doesn't show up without macOS theme :thinking:

1 Like

Looks like you are onto something!

With only one of Folding in Code Mirror Editor (v2.0.1) or macOS theme (v1.3.13) enabled, no grey bar. With both enabled, grey bar appears.

Marking this issue as resolved, since it appears it's not a Joplin app issue, but a plugin issue. Have posted to both of the relevant plugin threads.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.