After iOS sync, no tags on mobile device

Hi, all,

After syncing some 2,000 notes between Joplin on my Macbook Air and my iPhone, it seems the notes sync'd OK, but on the iPhone, the tags list is blank. Trying to figure out why notes made the transfer but not tags.

Log says there was a problem with long/lat info for one note. (See screenshot)

Could that be the problem? I could simply delete the note, but I don't know how to find it using the very long code for it in the log (putting that code in Search yields no result).

Guidance would be appreciated!

Mac system: 10.15.7
iOS: 14.2
Joplin version 1.4.18 on Mac, 10.4.1 on iOS

Thanks!

David

When I did a migration amongst several PCs and Android phones I had a few that also didn't show tags. I checked the next day and they were there. Maybe yours's will show too.

1 Like

Your log is showing an error with the sync lock. Could you provide some information about what you're using to do sync e.g Nextcloud, Onedrive, etc. ?

Hi,
Sure. Sorry, I forgot to include in my first msg. Sync is via Dropbox.

David

So in the absence of any further replies here I tried deleting Joplin from my iPad and reinstalling it, then syncing from scratch.

Same result as before: Notes came over fine from Desktop, but no tags. And a note that I created on my iPhone appears in the iPad Joplin -- but not on the desktop Joplin. This suggests that the iOS devices are syncing with one another separately from the sync they do with the Desktop.

Wish I understood what was happening here. I like Joplin a lot but without a complete and reliable sync I can't make much use of it.

Mac system: 10.15.7
iOS: 14.2
Joplin version 1.4.18 on Mac, 10.4.1 on iOS
Sync is on Dropbox

David

Any error in the log other than what you've posted initially?

Yes! "Cannot acquire sync lock" and "user denied access to location"

Wondering if I should delete all sync folders on Dropbox and start over?

D

Apologies. The log I screenshotted is from my iPhone. The log from the iPad shows no errors.

This leads me to speculate that the source of my problems is the iPhone sync setup, and that perhaps I should delete and re-install on the phone. Would that make sense?

David

It might just be that you need to let it sync on the device that has the tags, or maybe there's an error there. In that case you need to check the log, and for information the numbers on the left means month/day. So the screenshot you've posted is for errors that happened 4 days ago so it's probably not relevant (and indeed lock issues are usually temporary).

Hi, Laurent,
Thanks.

It has now been a week and nothing has changed. Sync works fine on 3 devices (computer, iPhone, iPad) but there are no tags ever on the iOS devices. Logs from the latest sync (a few minutes ago) show no errors. But there are no tags on the mobile devices.

Well, except one. I created a test tag on my iPhone. It syncs with the iPad but not with the computer. So I have one tag, created on the phone, that syncs with the iPad. Meanwhile, the hundreds of tags on the computer have never sync'd.

The device that does have the tags -- the computer -- is not reporting errors either.

I am starting to suspect that there are two different sync locations somehow. Perhaps I should delete sync lock files and create new ones? I don't see how I would do that, but I maybe you can tell me, if you think it is worth a try.

David

PS Here is the latest log from the computer, which again is the device that does have tags.

<</Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:38:16: Synchronisation is already in progress. State: in_progress
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:42:49: Saving settings...
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:42:49: Settings have been saved.
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:43:12: RevisionService::maintenance: Starting...
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:43:12: RevisionService::maintenance: Service is enabled
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:43:12: RevisionService::collectRevisions: Created revisions for 0 notes
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:43:12: RevisionService::maintenance: Done in 108ms
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:43:16: Running background sync on timer...
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:43:16: Preparing scheduled sync
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:43:16: Starting scheduled sync
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:43:16: Synchronisation is already in progress. State: in_progress
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:43:21: CommandService::execute: synchronize
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:44:47: Saving settings...
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:44:47: Settings have been saved.
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:48:16: Running background sync on timer...
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:48:16: Preparing scheduled sync
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:48:16: Starting scheduled sync
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:48:16: Synchronisation is already in progress. State: in_progress
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:50:35: Saving settings...
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:50:35: Settings have been saved.
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:53:12: RevisionService::maintenance: Starting...
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:53:12: RevisionService::maintenance: Service is enabled
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:53:12: RevisionService::collectRevisions: Created revisions for 0 notes
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:53:12: RevisionService::maintenance: Done in 116ms
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:53:16: Running background sync on timer...
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:53:16: Preparing scheduled sync
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 21:53:16: Starting scheduled sync
/Applications/Joplin.app/Contents/Resources/app.asar/node_modules/@joplin/lib/Logger.js:165 >>

1 Like