Adding a new android device to Joplin Cloud

Android version 7.0 on Samsung Tablet
Joplin version 2.6.8

I have a Windows PC and an android phone both running Joplin using Joplin Cloud which I have moved from Nextcloud/Cloudamo with E2EE to Joplin Cloud with E2EE . To do these I made sure that they were in sync and then just changed the sync target; for the PC I used the “Re-Upload local data to sync target” option, for the phone I just sync’d and waited a while. All is well.

For the Samsung device I’m re-installing the software to have a clean install and have a problem getting it to work properly, probably a configuration mistake.

On the Samsung tablet I deleted the app and re-installed from Play Store. As normal the Welcome notebook was installed. I then configured the sync target as Joplin Cloud with email address and password, granted the app permissions for camera, location and storage and waited. The sync finished (“Completed…..” message) but nothing had been brought from the server. (btw, the PC and the phone still work fine.)

I’ve tried again, just in case I had made a mistake, same result. I was at least expecting a message asking for the encryption password, is that right? But it did not appear.

Any help appreciated.


It seems from the Joplin Log that as the encryption master key is not loaded then it will not try to sync with the notes on the Joplin Cloud.
How do I get the master key loaded on the android pad device. Should I use the Encryption Config section and enter the encryption password??
Thanks for any help.

It will still sync the notes, even if the encryption key is not loaded. But actually it should be loaded since it's first thing it fetches. Please post a screenshot of your Encryption screen (under Config) to see what the issue might be.

Thanks for the reply. There was no encryption enabled, so I enabled it and entered the password.
Screenshot attached. The master key here is different to that on my phone, is that right?

I don't quite follow what you've done. You should enable encryption only on one device, then just sync the devices.

OK, so that is where I started, I think. I deleted the app from the pad and downloaded it again to start afresh. Set the sync target as Joplin Cloud, ran the sync and expected that I would get a message to ask for the encryption password, but did not. The sync process ended but did not pick up anything from the server. (also see my first post). Now I think I am digging myself a hole, in that I've incorrectly entered the password to set up encryption on the pad.
What should I do next?

Just after your first sync (without doing anything more), please post the content of the Status screen and the Encryption screen.

Also make sure that on the other device you've completed a full sync, because that could be the problem - maybe not everything's on Joplin Cloud

I ran sync on both other devices before installing version 2.7.2 of the app, then entered the Joplin Cloud email/password, then did the sync. The sync took around 30 minutes. The screen shots are below. Is it relevant to send you the information on the LOG. Is there an easy way to export it??

I've now noticed that if I use the Check Configuration Configuration option in configuration settings then I get an error message saying that the URL, user name or password is incorrect, and "Network request failed".
I tried to sign on the page and that works fine, so I think the email address and password are ok.
Any more thoughts?
Thanks for your help!

No matter which sync target, it never happened that the app would say the credentials are incorrect when they are correct, so most likely you need to check this again. Maybe type it manually just to be sure.

I've changed the password to make it really simple to type and it still comes up invalid. So, I guess its not the password/email that is incorrect. The password/email combination works fine on my android phone and windows PC. Any thoughts on what could be specific to the Samsung tablet?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.