Home / GitHub Page

1.0.227 regressions

Although I really like the fast development of my favorite tool, some annoyances seem to creep up. The general feel is that more bugs than features are introduced.

  1. Search, multiple word as advertised below does NOT work, it simply gives all notes containing any word. Cannot find my notes anymore…

Multiple word Returns all the notes that contain all these words, but not necessarily next to each other. dog cat - will return any notes that contain the words “dog” and “cat” anywhere in the note, no necessarily in that order nor next to each other. It will not return results that contain “dog” or “cat” only.

  1. Gtrl-G jump or goto feature, completely freezes the screen for a long time and than gives false results. I used to jump to the same note in older revisions with 3 key-presses, now it just cannot find it until i have written a complete word, and even then…

  2. Ctrl-F searching does not seem to mark in ACE markdown editor, and will not jump to the line. Switching from editor to viewer is a disaster in long notes, since the note seems to scroll a few pages. It makes jumping in notes impossible. While typing in the editor sometimes cursor scrolls out of view with no apparent reason. Switching back to viewer i get a flash of the correct rendered note and than a jump to another location in the scrollbar. All in all i am better off using an external editor (in my case Typora) which gives a far more solid and usable experience.

Okay I leave it at this but there are more regressions. Joplin is heavily used by me, during the day and evening, So please bear with me in my criticism.
Cheers Lourens

1 Like

The problem is 227 should have been a pre-release but I’m mistakenly made it a regular release. For future versions, I plan to keep most of the changes in pre-releases and only create a release once everything is stable.

2 Likes

Sorry about that Laurent,

I imagine that it is very difficult to oversee all changes and mutual interrelations, I have my thrust in you. I am sure that at some time you will hold off any big changes in favor of some good bug-hunting to improve daily usability of the basic functions.

Lourens

No problem, I know that regressions can be annoying and my plan indeed is to slow down the official releases, and move new features to the pre-releases so that they can be better beta tested. That also leaves me more room to develop without breaking people’s workflow :grin:

Could you provide more details on what’s not working? I’ve just tried and searching two words work for me.

I believe it’s always been like this? With Ace Editor, if you search, only the preview will have highlighted words.

1 Like

Okay 1.0.231 has fixed some issues. With multiple word search I was expecting more words would narrow down the results, in previous release more words would be OR instead AND so the results list became longer.

Ctrl-G is down to it’s fast speed again.

For Ctrl-F I have my hopes on developments in Codemirror editor.

However this release in Codemirror it constantly seems to flip to the split-screen. I need to do Ctrl-L twice to get back in normal view. When I search: Split-screen. When I click the note in notebar Split-screen. When I click sidebar: Split-screen – please stop?

In the old settings i have always had Split-screen completely disabled since my monitor for Joplin is in portrait mode and 4 Columns are simply unusable with narrow screen. Maybe if the editor screen was split vertically instead horizontally from view, it would have been ok (back to Wordperfect 5.1.underwaterscreen?). Now back to ACE again for me. Also there is no dark-mode rendering so that makes editing nearly impossible with the crazy colors in Codemirror.

The screen should only split when you initiate a search, is this happening for you at other times? I definitely get that it can be annoying though (especially when you have split mode disabled). The reason for doing it was because the searching now takes place in the editor rather than the viewer, this is new behaviour so we need to communicate with with users somehow, but also searching with just the viewer open no longer works. How do you propose this should work instead? Would it be enough to switch to just the editor rather than split view? (depending on settings of course).

edit: and if anyone else from the community has an opinion, I’d like to hear it!

Can you elaborate on the lack of dark mode? A screenshot maybe? Do you just not like the colors used in syntax highlighting? This is how dark mode looks for me


And here’s ace for comparison

2 Likes

You ask if this happening at other times. For me this also happening when changing notebooks. I have “Viewer” selected, and when I change notes withing the notebook everything fine, but when I change notebooks it’s changes to “Split View”.

@Technik-J welcome to the forum.

Are you using the beta Codemirror editor? If so, see this post.

1 Like

@dpoulton Thank you. Yes I tried Codemirror editor, and noticed this issue. From your linked post I understand that the fix, probably, will be in the next release.