Why doesn't the mobile app ask to resize image down to 1920p?

Using Joplin Mobile 2.11.32 (Android)

When I insert an image on the desktop app, it asks me if I want to resize it down to 1920p, which I think is a good thing to do.

But it seems on the mobile app it doesn't ask that, an imports the image at its original resolution.

Is this behavior normal ?

Basically what I ended up doing is to never use the mobile app to insert an image, always the desktop app.

I have exactly the same issue. I will be great if mobile apps will be able to resize pictures, because now it is really limited or end up wit adding big files without reason :confused:

Make sure that the "resize large images" setting is enabled:

If it doesn't resize large images when this setting is enabled, that's a bug!

1 Like

I have just tested with "Always ask" (not asking) and "Always resize". Both not working :confused:
version 2.12.2

I've just tried and it's working fine for me with "Always ask". Could you provide the image you are trying to attach?

I have played with this image. Not working for me. Just tried second time with this.

Looks like image is resized when I have added it here because here is info

Hmm, yes it's 1920px here, so it wouldn't be resized. Are you able to upload it somewhere so that we can download it as it is (without being converted by some service)? Or compress it as zip first

20230909_190715.jpg.zip (2.0 MB)

ZIP should work :smiley:

ZIP should work :smiley:
20230909_190715.jpg.zip (2.0 MB)


You should be able to download. There is option of direct download without need of login to pcloud

I hope that you see above post because I got message that some is hidden, probably when I have tried to send ZIP file :wink:

Thanks, it works fine now too. My app wasn't up to date, didn't have the "resize" option (I guess it's been added fairly recently).

I just upgraded to version 2.12.3 on Android, it works fine. Try and upgrade to the latest version. Are you on Android or iOS ?

I just tested with your 4348x3251px picture, and indeed it doesn't ask to resize.

There must be something special with it, because I tested a dozen other pictures, it always asked to resize. Can you try with some other pictures ?

I just tested with your 4348x3251px picture, and indeed it doesn't ask to resize.

It is simply photo from my phone - Samsung A52 so quite popular model

I have tested picture downloaded from internet and indeed it was, resized. Than I have tested with some other pictures from my gallery and it works 50/50. Some are resized some not :confused: Don't know what is an issue

I think I have found at least one different between photos which are asked to be resized with this which are not.

When I add to Joplin app original photo -> Joplin ask to resize it.

When I add a little cropped but still big photo - Joplin not asking to resize it :confused: The same with scans which I always crop during scanning.

Do you have any idea why is like this?

The library used for checking size reports 1087x813 for this image.

It seems that the Image.getSize() doesn't report the pixel size on Android

We might need this package

I was just looking into this and notified the upstream package:

That react-native-image-size package unfortunately doesn't even build (Java code is invalid), I think the owner messed up a merge and didn't check if it was still working: