Why does Joplin open port 3000?

Running Joplin 2.9.17 on macOS.

I need an application to start listening on port 3000, but Joplin already has this port opened. So I have two questions:

  1. Why does Joplin need to open this port?
  2. How can I reconfigure it to use a different one?


Joplin doesn't open port 3000. Maybe a plugin does something weird?

Thanks for the info, I'll investigate into this

You can also try disabling the web clipper (if enabled in settings).

Webclipper is a different port (above 40.000).

It's the cursor sync plugin (GitHub - ylc395/joplin-plugin-better-markdown-viewer: Keep Cursor Synced Between Editor and MD Viewer) that opens a websocket on


I was just wondering as well and opened an issue for that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.