Home / GitHub Page

Webclipper port with joplin terminal

Could it be possible to open the port of the webclipper when using joplin terminal ?
Thus we won’t have to start the Joplin Desktop and thus joplin-web could be used on a dedicated hosting services too.
Today all run on a workstation which blocks some users for joplin-web

It’s still the same issue, we’d need to finish the headless server feature: https://github.com/laurent22/joplin/tree/headless-server

ha I knew something existed about it but did not find it.

Hope to see it soon :slight_smile:
THanks for all the work!

I’ve added the server command in v145, could you give it a try?

server <command>

    Start, stop or check the API server. To specify on which port it should run, set the api.port
    config variable. Commands are (start|stop|status). This is an experimental feature - use at your
    own risks! It is recommended that the server runs off its own separate profile so that no two
    CLI instances access that profile at the same time. Use --profile to specify the profile path.

For example, in one terminal you can run joplin server start, and in another joplin server status to check the status or joplin server stop to stop the server. You can also make the server run in background using joplin server start &.

Thanks, I’ll try this evening

A post was split to a new topic: CLI error updating from 141 to 145

the server start but ignore the token parms

00:43:39 [foxmask@localhost:~] 1 $ joplin server start
2019-09-09 00:43:48: "Starting Clipper server on port 41184"
2019-09-09 00:43:54: "Request: GET /folders/?token=fff6170db0bbb65ff563fc5977d533a0b4a60ce3203b8c6252f500fbf9e37211a056dcc8f7cf6239e8745a90bd62da0ff328fcc6e8162552139e382301520ca8&fields=id%2C+title%2C+created_time%2C+updated_time%2C+user_created_time%2C+user_updated_time%2C+encryption_cipher_text%2C+encryption_applied%2C+parent_id"
2019-09-09 00:43:54: "Request: GET /tags/?token=fff6170db0bbb65ff563fc5977d533a0b4a60ce3203b8c6252f500fbf9e37211a056dcc8f7cf6239e8745a90bd62da0ff328fcc6e8162552139e382301520ca8"
2019-09-09 00:43:54: "Error: Invalid "token" parameter
Error: Invalid "token" parameter
    at Api.checkToken_ (/home/foxmask/.joplin-bin/lib/node_modules/joplin/lib/services/rest/Api.js:180:49)
    at Api.defaultAction_ (/home/foxmask/.joplin-bin/lib/node_modules/joplin/lib/services/rest/Api.js:184:8)
    at Api.action_tags (/home/foxmask/.joplin-bin/lib/node_modules/joplin/lib/services/rest/Api.js:301:15)
    at Api.route (/home/foxmask/.joplin-bin/lib/node_modules/joplin/lib/services/rest/Api.js:138:42)
    at execRequest (/home/foxmask/.joplin-bin/lib/node_modules/joplin/lib/ClipperServer.js:157:39)
    at Server.server_.on (/home/foxmask/.joplin-bin/lib/node_modules/joplin/lib/ClipperServer.js:199:7)
    at Server.emit (events.js:198:13)
    at parserOnIncoming (_http_server.js:677:12)
    at HTTPParser.parserOnHeadersComplete (_http_common.js:109:17)"

I made another try and it’s working

I did not start the server with the expected profile path

 joplin --profile ~/.config/joplin-desktop/ server start

looks better !

Thanks a lot !!