What is this welcome feature called and how to use it in other notes?

Joplin 2.7.15 (prod, darwin)
macOS 11.6.5
No Plug-ins installed

While clipping a selection from a web page into Joplin, I noticed the paragraphs were indented, like so:

Checking markdown viewer, this is what I see:

The paragraphs were probably indented by this (just a guess):

If so, what are those red dots and how do I use this welcome feature in the future without copying/pasting it from this note and applying it to other parts where indentation is desired?

1 Like

Did you add the red?

If not, my first hunch would be that they are real 'dot' characters (as above in the '4 primary works / 15 total works" line), but are white on the page, and are used just to get reliable spacing where whitespace can't be chopped up.

However, if this is coming from Goodreads, on my end, there is a dash in front of each of those indented items:


I'm not sure why you're getting two dots, though. I dumped the copy/paste from Goodreads into both Joplin and Obsidian and, on my system (Windows), I get the dashes as shown.

1 Like

I think you're right, I might have added the red dots in the example I included. I apologize for not using the original note where I first noticed this occurrence; I'll try to find that one and post it with a link.

I forgot how I went crazy copy-pasting those dots all over my other notes (it's a feature I've wanted for so long and didn't really like the suggested fixes I found online, simply resigning myself to the fact it was never going to happen. So imagine my excitement when I saw the indented text without using bullets or dashes). Unfortunately, I can't exactly recall what was the first one at the moment, but as mentioned, I'll find it asap.

Thanks for the FYI.

Added to Clarify: I did not do this deliberately to show off or anything remotely like that, no hidden agendas here. I do not know anything about markdown or any programming language, not even HTML or unicode. I'm just a copy-paste, click and tinker, how-does-this-work, and very new to Joplin kind of guy. Likewise, I was curious why a note had indented parts without dashes or bullets. That's it. I clipped (or copy-pasted) a bunch of text from a webpage and can't replicate what happened as I cannot remember what that page was. I didn't go to discourse.joplinapp right away to ask, I was just happy it happened and starting applying this "feature" to other notes. If only I could recall things correctly. Now, I can't seem to back-trace my steps so I can give a better sample. My sincerest apologies for that.

2nd Reply

I can't seem to find it; I tried clipping the goodreads selection again, hopefully to replicate what happened but just got the same results as you posted—a dashed list. I perused all my notes and the one I posted previously is the only one that has the red dots in question, I don't know exactly why (don't you just love anomalies? lol).

Sorry to bother you and not be helpful at all. Nevertheless, I still appreciate your response and now at least have an idea what's happening. Thanks again.

If you still have a note with these red dots, maybe you could export one to a jex and share it here? We'll be able to figure it out pretty quick with a copy of the dots. To me it looks like a unicode space. I haven't been able to reproduce that with the red dot though.

In general, these aren't great to use because they look just like a regular space, but will affect the final rendering.

Below is an example using the unicode em quad character:

Regular text
Text that follows an EM Quad
Text that follows 4 spaces

Edit: Below was my original message, but I kept getting the "Sorry...upload error" popup while trying to upload the file. Where can I share it alternatively or is there another way to avoid the error mentioned? Thanks.

Thanks for your reply. Here is a copy of the note you requested, but am not sure if I exported correctly though. Do advise if I flubbed it:

I'm not sure if this helps, but I opened the jex file in a text editor, and here's a copy of a selection with the pertinent red dots:

The Hallowed Hunt
Penric's Demon
Penric and the Shaman
Penric's Fox
Penric’s Mission
Mira's Last Dance
The Prisoner of Limnos
The Orphans of Raspay
The Curse of Chalion
Paladin of Souls

Do you have privacy badger installed by any chance (or similar privacy extension?). I found that it stopped me uploading images with that exact error.

If you can attach the jex it would be better as I'm guessing discourse is altering the original character.

Indeed I do (as well as a bunch of other privacy addons). I'll try disabling it and get back asap.

Here ya go! Thanks for the suggestion, it worked. Also: @CalebJohn

mysterious_red_dots.jex (12.5 KB)

Well this is the mysterious dot and why it is red (cm-invalid char is red by default it in the theme it seems):

<span class="cm-invalidchar" title="\ufffc" aria-label="\ufffc" cm-text="">•</span>
1 Like

Err...is it bad? Sorry, I'm really not well-versed in any of this, just started using Joplin a few months ago. I just noticed the formatting of a note, thought it was a feature, was curious how to use it, that's all. Apologies if I was doing anything illegal, as mentioned, I'm just a blundering noob tinkering around. Thanks for everything.

No no, don't mean to imply you did anything wrong, just stating the fact of what Joplin thinks that character is and why it is rendered in red.

It actually doesn't show the same for me in my markdown viewer.


So yeah, no idea really what it is, all I can say is it isn't standard markdown.

Oh, I see. No worries, just happy someone took a peek at it. You the MVP :pray: :facepunch: :+1: Thanks so much, really appreciate this. Cheers!

I’ve seen the red dots happen when copying text from Fresh Desk into Joplin. I never added the dots with the instance of email seen.

It’s almost like the hidden formatting of Fresh Desk web page is being identified in Joplin. Not saying it is a bad thing, quite the opposite.

I use a markdown renderer in a brave browser.
Those red dots has helped me with sorting out why my Chrome markdown renderer for Brave had issues with the rendering the markdown code.

  • I copy the rendering results and paste into Joplin, fix it by removing the hidden format, copy from Joplin and back into Brave fresh Desk, render and it’s fixed for my Fresh Desk post.

I've had similar problems from Facebook:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.