What does that mean after running a Joplin "Delete local data and re-download from sync target"

Operating system


Joplin version


Desktop version info

Joplin 2.13.15 (prod, win32)

Client ID: 847b324dc209404f9a3327c9368b216e
Sync Version: 3
Profile Version: 44
Keychain Supported: Yes

Revision: 7d2c1c0

embedded tags: 1.0.0
Favorites: 1.3.2
Note Tabs: 1.4.0
Simple Backup: 1.3.6
Text Colorize: 1.2.5

Sync target



Markdown Editor

What issue do you have?

Hi there, I got a message as in below screenshot when I ran a Joplin synchronization advanced setting as well as the so called "Delete local data and re-download from sync target", what does that mean?


The rich text editor is disabled if there are resources that haven't been downloaded that are attached to a note.

While these resources are being downloaded, only the markdown editor (or probably an external editor) will work.

Hey, thanks for your reply.

Might you happen to know what should I do to enable Rich Text Editor? I don't even know that is a thing (To enable Rich Text Editor).

I don't see an option for "Enabling Rich Text Editor" as in below screenshot:

But the "being downloaded" part had completed already, this is where I am, what should I do?

Clicking the "toggle editors" button should switch between the rich text editor and the markdown editor:

The markdown editor should show a split view, with markdown on the left and the rendered markdown on the right. (Though just the markdown or just the rendered markdown can be shown by clicking the toggle editor layout button: toggle editor layout button).

But the "being downloaded" part had completed already, this is where I am, what should I do?

I'm not sure... This could be a bug. Does this happen for all notes or just one or two?

I just made a screenshot(1) for visual communication of what I saw as below attached, but seconds before I make this post and upload the screenshot, the issue of the subject note just gone all by itself..., I don't like what I am going to say, but a bug usually stays as a bug, so this is SOMETHING else. Anyway, I am still observing the issue, it happened to quiet a few notes but now I don't seem to be able to fine them (the issue with the notes).

I haven't had this kind of SOMETHING for quiet some time, anyway, that is another story.

(1) Reference screenshot:
The grey out area keeping me from any keyboard operation ▼:

A follow up to my previous reply, the issue, is now on and off, back and forward, the issue is like solved in last 10 minutes and appeared again in the next 10 minutes, so I am still open to any suggestion aiming for a final solution.

Just to be clear, the grey-out shield thing mentioned in my previous reply appears for a while and disappear for a while. :expressionless:


I can access "Toggle Editors" through Crtl+Shift+P keybaord hotkey (As attached screenshot 1) and then, I can see what an average Joplin user see a split windows including a note view and a mark down editing view, but when I clicked on "Toggle Editors" button as in your screenshot (or as in attached screenshot 2), it came back to the problematic note view. So, the user experience of this incident becomes tricky, so I would not call this a final solution, just so you know.

Attached screenshot 1:

Attached screenshot 2:

1 Like

Just a quick update to this thread and I am still hoping to get further suggestion and/or opinion.

The Joplin note in the screenshot of my previous reply, if I removed some of the URL (for example, internal URL of Evernote), the problematic note will turn into a normal note.

I hope someone who knows can shed some light.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.