Web clipper 2.1.3 not working

Make sure you exit the app config screen when the clipper is seeking permission, because the dialog only shows up from the main screen (where the note editor, note list, etc. are).

And if that doesn't work please provide as much log as possible: Joplin Web Clipper | Joplin

Bingo. When I exited the config screen, I got the message in the Joplin it needed my permission, I granted it in the dialog box, the Web Clipper was successful! Thank you so much for that statement. You have no idea how much I use that little clipper! Thank you, thank you, thank you!!!

1 Like

If you hadn't seen that before how were you previously able to try, "revoking permission and regranting permission."?

That's real cute. Let me see if I can explain it so I do not seem to be stupid or a liar. I revoked and granted permission many times but I never exited the config screen so I am guessing it did not complete the operation. But when I saw laurent's gracious reply to make sure I exit the config screen because it only shows up on the main screen, I did that and when I exited the config screen the permission request was right there on the top of the main screen, I granted permission again and then web clipper worked.

Again thank you so much laurent!


My question was serious although possibly it could have been a bit more detailed.

The permission banner is not visible whilst in Joplin settings. Upon leaving the settings you saw the banner and authorised the clipper. It now works for you. I am glad for you.

However whilst in the settings, and before you could see the banner, you were doing something with the options that appeared to be authorising and rejecting the clipper permissions. So convincing that you still feel that,

I revoked and granted permission many times but I never exited the config screen so I am guessing it did not complete the operation.

I just wondered what that was you saw in the options that appeared it could be the clipper permissions? This so that if anyone else is having problems we'll all know what a possible solution is.

This permission change upgrade for the clipper / Joplin has caused many people problems for many different reasons.

I am just posting this to explain the reason for my earlier post and make it known that I was never inferring anyone was stupid or a liar.

1 Like

Yes the migration was a bit of a mess, but it was difficult to do otherwise since maintaining compatibility with previous versions was not an option due to security issues. Then there was that Firefox bug, and also browsers automatically updating extensions.

I think the remaining issue is what's affected DTregembo, and probably others (including myself!), is that the notification doesn't show up in the config screen, even though that's where you turn the clipper service on and off. I'm planning to do something about it, either display the notification (difficult), or automatically exit the config screen when that notification is received (easier to do).

Yes. The main reason was that the browser upgrade was out of your control with many people having their browser auto-update (myself included!). So without ever visiting the forum to see what may soon be happening their clipper - Joplin link would just break.

I apologize, I guess I jumped to conclusions as it appeared you were saying I did not do what I said I did, but maybe we are talking about different things as I may be using different words or meaning something different from what you folks are saying.

. When I said I was revoking and regranting permission I was going under the options dialogue to the web clipper section and disabling web clipper and then reenabling web clipper. Then I would go to my Brave chrome browser and see if it was working which it was not. I did this multiple times and even uninstalled and reinstalled web clipper grasping at straws to get it to work.

Then I read laurent's post saying I had to exit it in order for the banner to appear where I could authorize it. Once I did that the web clipper than worked again. So I probably missed the banner before when I exited from options or perhaps I waited too long to exit to see it, until laurent's post which made me realize the banner was not what I was checking under the options, but was on the main screen.

So again I apologize. What I thought yall meant by revoking and granting permission was the setting for enabling/disabling web clipper on the options page, while I am guessing you were speaking about the banner.

1 Like

There's no need to apologise. We are communicating through a forum and so saying what we mean in an exact and unambiguous manner is difficult.

We / I now know that some people may not see the banner and so assume that restarting the clipper service is what is required. With that in mind supporting other users gets a little bit easier.

Anyway, enough of this idle chit-chat, you can now carry on with your clipper-intensive research :slight_smile:


Update to my original problem.
I wish i could post a solution, but... it just started working.
Best guess i have is the right series of restarts or reboots?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.