Home / GitHub Page

Version 1.0.207 (and now 1.0.209) minor issue

Current Version: 1.0.209
OS: iMac 2019 macOS Catalina Ver. 10.15.4

Hi all!

Version 1.0.201, I believe, has this working correctly. I’m afraid of updating my MacBook Pro’s instance of Joplin for fear of this issue happening.

Whenever I’m working with lists, and say I go to the next line, and press “tab”, the item above the new bullet item/checklist item will indent - I’ll have to do a variety of different actions to try and get the new bullet to indent (ranges from tabbing the above line all the way, or first typing in the new line, etc). It gets a little annoying as sometimes it’ll do what I want when I’m trying to repeat one of the above actions, and other times it doesn’t.

EDIT: I’m noticing another issue with numbered lists. Indenting isn’t auto-updating the numbering and now I’ve got into this situation.
Screen Shot 2020-05-18 at 09.54.13

As stated in the title, this issue is present in both 1.0.207 and 1.0.209 (it’s a little better in 1.0.209 but still not great.)

Has anybody else hit this issue?

Thanks!
Hector

Yes! I’ve seen this one when editing one of my notes but when I tried to create a minimal example where this would reproduce I could not. Seem to occur semi-randomly for me.

UPD
This was in the old editor, not WYSIWYG.

1 Like

Yes! This is in the old editor. I’m scared to try out the new editor because of the disclaimer at the bottom LOL. I use this for important stuff for work, so I don’t want to lose anything. lol.

Here’s a video:

Yep, same issue, though for me it was with nested lists but looks like it’s even easier to reproduce than I thought.

yeah, it happens at all levels for me, unfortunately LOL. Hopefully there’s a fix in store for this :crossed_fingers:t4:

+1 :wink:

fixed in Joplin 1.0.214 (prod, darwin) / Mac OS 10.14.6
thank you ! :pray:

1 Like