Homepage    |    GitHub    |    API    |    FAQ

Untagged

This is a WIP plugin to find notes and todos without a tag and give them a special tag. This tag can be renamed to what the user wants (eg. "Untagged", "Uncategorized", "No Tags", "Tag Me", "To Be Tagged", ect)

2 Likes

Thank you. If you don't need to add a custom tag, you can also search directly:

-tag:*
2 Likes

You are a genius! With your little search tip you've simplified this plugin so much!

The plugin has now been published!

Does it take a certain time before it finds an untagged note? It found one from several days ago, but is not finding a test one that I created. I've restarted Joplin a few time to no avail.

It should find it near instantaneously, At least within a few seconds, though it does take a while to iterate through each untagged note, maybe 1 per second. Are you sure the test note contains no tags at all?

Still hasn't found my test note, and I'm sure there are no tags. I'm on Joplin 1.8.1. Could that be the reason?

Also, when I deleted a tag from a previous note, that wasn't found either.

In fact, when I just did the -tag:* search, there were 6 other tagless notes that weren't found by the plugin.

Thats very strange. Especially seeing as the plugin uses the search endpoint with that exact query. Try deleting the untagged tag to autorecreate it

I have only taken a quick look at the plugin:

  • tagNotesWithoutTags and untagNotesWithTags is called continuously in an endless loop. I think this could result in x calls per second
  • joplin.data.get does not respect pagination, so all data is never displayed
    Joplin Data API | Joplin

Deleting the untagged tag sort of helped. It did find the test note that it couldn't find before. However, the name of the tag is strange: >>71557>>untagged<<71557<<. Also, it still doesn't find any new untagged notes I create.

More strange behavior: I renamed the tag as .untagged. After a little while, it renamed itself as >>05805>>untagged<<05805<<.

That code triggers if it tries to create the untagged tag and it already exists. You would then rename it to something else. But tomorrow after I get some sleep, ill get rid of the hardcoded tag ID and tag names to keep track of which tag to assign to untagged notes.

I've updated the code to work via tag titles instead of hardcoded tag IDs. Update the plugin and see if your issues are solved :slight_smile:

Sorry, but still not working for me. It found the one existing untagged note, but it's not finding new ones I create.

Thats very strange.

Strange, indeed. I just tried installing it again, and got the same problem. It wouldn't have anything to do with another plugin, would it? I do have most plugins installed.

Hmm, im not sure. My suspicion is that those noteshave another tag or for some reason, arent showing up in the "notes without a tag" search that untagged uses

But manually searching for -tag:* finds them.

When I enable this plugin, Joplin takes ~98% of my CPU constantly. I have tried all the plugins one by one (i.e disabled all and gradually enabled them) and I am positive that this plugin is the cause...
Could this be in connection with the aforementioned search-loop that is constantly runnig?

Also, does anyone have an idea how this plugin arrived at a version of 2.0.1 (the second highest of all plugins) in just 16 days since creation? :smile: