Syncing Via a USB drive?

I just got started using Joplin and I tried to set up a USB drive to be used to sync between my (Windows 10) PC and my (Ubuntu Linux) laptop but it doesn’t seem to be working (I have both of them set to file system sync pointing to the USB drive, the drive does get files on it, but when I press the button to sync nothing new appears on my laptop when there were new notes on my PC (which it said were synced to the drive), or it causes the failsafe to activate. This is probably me doing something wrong rather than a bug but any help? I just want to sync between my PC and Laptop without having to use any kind of cloud service or set up my own server.

What is failsafe?

Also, it is difficult for us to trace down problems if you don't upload the log files.
So please make a new note on your PC, sync it to your USB drive, plug in the USB to your laptop, try to sync and then upload the log files from both your PC and laptop.
Also, please mention your Joplin version and Ubuntu version you are using.

The failsafe is the option in the sync settings that “Does not wipe out local data when sync target is empty (often the result of a misconfiguration or bug” (quoting from the settings)
https://paste.ee/p/b2XHq this is the log file from my PC, only the part from today because the paste wouldn’t let me do more, I hope that’s okay
The log file on my laptop comes out as being unreadable (as in, can’t open it), but it’s running Ubuntu 18.04. Both are running the most recent version of Joplin.

From your PC log file, it seems that the sync target you have set is incorrect or Joplin thinks it is incorrect. If you don’t mind, would you please post the directory that you have set under the sync target settings?

I don’t quite understand what an “unreadable” log file in a Linux system would be. Does it not exist or does it contain garbled characters when opened in a text editor (in which case Gedit might also give a warning saying that opening the file may damage it)? Unless you have run Joplin as root, all log files (and other config and metadata) will be stored in your home directory with your user being the file owner and so you should be able to open it.

I just have the target for the sync set as I: (which is what the drive comes up as)

And by unreadable I mean when I try to open it it gives me an error message saying that it’s encoded in a way that can’t be read, and that trying to open it might break something, so I left it alone

Is the drive label consistent (ie, do you always get I: for the USB drive)?
If it is persistent, then it would be nice if you could post a screenshot of the sync folder (opened in File Explorer).
As for the Linux log, you can ignore the warning and open it anyway. Even if you do “damage” it, it will not be a big deal since it’s a log file. So then you can paste the contents of the log file.

yes, it is consistent. I always get I: for that drive. I’m assuming by the sync folder you mean where it’s synced to which would be this https://feen.us/7l92qi9p.png, if you mean the .sync folder in there it just has version.txt (which just contains “1” and nothing else) and nothing else
The linux log file says it’s not UTF8-compatible and if I force it open (none of the options load it properly, it seems) it’s just blank

This indeed is a very unusual problem, and I haven’t seen this happen before. I’d suggest trying the following:

  1. Delete the log file on Linux, try to sync to the USB drive and post the log file subsequently generated - if it is not garbled.
  2. If the garbling continues, the installation of Joplin has probably got corrupted. It’ll be a good idea to remove the Joplin related directories under ~/.config as well as files under ~/.joplin and then run the installer script again.