Homepage    |    GitHub    |    API    |    FAQ

Syncing to a new WebDAV target and notes are either invisible or conflicted

  • Joplin 1.8.5 on Windows
  • Syncing to a WebDAV target (bytemark/webdav:latest)

I am trying to perform an initial sync to a fresh WebDAV target. When the sync is complete, all notes are either invisible or marked as "Conflict" (see screenshot). There is a different profile that went through this same process. It syncs to the same target (but a different subdirectory) and doesn't have this problem.

History:

  • For months, this profile was synced to a WebDAV target.
  • Last month, both profiles were switched to Joplin Server. We encountered some problems and have changed back to WebDAV.
  • The master copy of this profile is on an Android phone. The behavior when syncing to the WebDAV target was the same on Android as it is on the Windows app.
  • The profile files have been exported from the Android Joplin app and copied to a Windows 10 system. I just copied the files and renamed "joplin.sqlite" to "database.sqlite". The notes look OK in the Windows app before performing the WebDAV sync (see screenshot). The problem is when the notes are synced to WebDAV.

Debug log and screenshots are attached.

log.txt (98.5 KB)



I think I'm facing the same problem. I am migrating from Evernote. Having imported all my notes into Joplin (no problem with that) I set up the sync with my Nextcloud account and after the initial sync some notes are marked as "Conflict" and many others seem to have been deleted.
Really disappointing, but I'm confident it can be fixed.

Regards,
Juan

Yes, it is disappointing and frustrating. Sounds like we're both stuck with a non-syncing Joplin configuration. It would be great to get some help with this.

I wonder if there's a way to clear the "conflict" status so that Joplin will sync to the empty WebDAV target. I don't know if that's the actual problem here or if that's anything how Joplin works, I'm just speculating.

@johnz1 According to the logs, the notes on the sync target were deleted and modified locally.
That is why there are conflict notes.
Since I don't know what you have copy from/to and what went wrong on your various sync target, there is most definitely an inconsistent state there.

The easiest way to solve this problem is:

Steps to proceed before the sync when all notes are still there on your client:

  1. Export all notes as JEX File > Export all > JEX (You can check on a JoplinPortable instance if every note is included)
  2. Copy keymap-desktop.json, userchrome.css, userstyle.css and templates
  3. Close all Joplin Apps
  4. Delete %userprofile%.config\joplin-desktop
  5. Delete the Appdata on the Mobile device
  6. Delete all the content in your WebDav the Joplin folder
  7. Start Joplin Desktop
  8. Import the JEX File > Import > Jex
  9. Copy keymap-desktop.json, userchrome.css, userstyle.css and templates back
  10. Setup Sync on Desktop
  11. Wait until sync is completed
  12. Set up sync on the other devices

@jcv Unfortunately, there is no information in your post to help you.

For other support queries please indicate:

The version you are using. LATEST VERSION is not a version number!
If it is a sync issue, please let us know what you are syncing with.
If you report a problem with upgrading, please let us know both versions (from/to).
If you report a problem with the editor, please tell us which editor you are using (WYSIWYG/Markdown).
The operating system you are using.

If you can also please provide a log, as described here: https://joplinapp.org/debugging

Sorry for not replying sooner. I forgot to notify that I was finally able to sync after changing the settings from Nextcloud to WebDav. It probably doesn't make sense but it worked for me.

Best regards and again, sorry for not replying with this update,
Juan

7 de junio de 2021 7:05, "Jack Gruber via Joplin Forum" <cozic@discoursemail.com> escribió:

Thanks so much. This worked. Image files didn't make it, but there were only a handful so I was able to get them directly from the Android profile export. All appears to be well now.