Webdav sync problem after webdav address change

Hello, I am sorry if the answer is already somewhere in the forum, but I have not been able to locate it. I have installed Joplin on several devices, mainly MacOS and iOS. I use encryption.
On a Linux system I ran into a problem, I think it’s because I made a mistake and gave Joplin the webdav “root” address and not the …remote.php/webdav/Joplin address… then I changed it, Joplin requested to untick Fail-Safe mode, which I did, Joplin erased the four “Joplin introductory notes” but did not download any notes from the existing webdav directory. The synchronisation configuration check is successful.
This happened to me again (sorry for not being very clever or not concentrating hard enough… I made the same mistake putting the … remote.php/webdav instead of remote.php/webdav/Joplin in) on another Mac. Same issue.
Is there something I do wrong and do not understand about changing the webdav directory? I have read the Jolpin help page (but the issue there is the opposite, risk of data loss if you have local notes and then change to another directory…)
Any help would be appreciated!!
Thanks already!

Hello again,
I see that discussions are active on other subjects.
I have not been able to resolve my problem.
Is the absence of an answer from anybody due to the fact that my question is not in the right place or that I should be able to resolve it myself, to missing information in my initial post, to my question not being formulated clearly enough, to low importance and a delay of >5 days being normal in this setup (which I could obviously understand) or to the fact that there is no easy answer?
This is an honest inquiry just to know how I can move forward...
Looking forward to hearing from you :slight_smile:

The fail-safe is there to prevent you from deleting all your data due to a mistake. So normally you would fix that mistake instead of unticking the fail-safe (which will result in all your data being deleted).

In your case, I think you need to start from scratch. Do you have a backup of your data?

If so, clear your local app profile, clear the sync target, then import the backup and sync again. And never change the WebDAV path. If you need to do that, make a backup and start over.

Dear Laurent, thanks a lot already and sorry to have insisted.

I hope my explanation was clear. In fact, I did not loose any data but two devices do not sync (no notes) after the WebDav address mistake and change.
(Indeed, sync works fine on most of my devices but the two I mentioned, and all my data is still there (and thus readable) in the Joplin directory of my WebDav server. The two devices where I made the mistake (one Linux, one Mac) remain empty despite correct sync targets.)

So, do I understand your explanation correctly for this case that I should clear the local app profile, import the data (which I can easily export on one of my Macs as a zip archive in Joplin format) into Joplin on the two problematic devices and then sync?
In that case, could you just tell me how to « completely clear » the local app profile ? Is that in the Joplin settings (which I cleared and started over before posting my question, but without importing data) or do I need to erase some kind of a system/profile file?

Sorry to inquire more, but I don’t want to make a mistake which could be problematic.

Thanks again, best wishes, Felix

(PS Again, though, excellent app, glad there are people like you out there who make this kind of independent stuff which is just functional and well designed. An it made me return to my piano with an old ragtime I used to play :wink: ...).

From the look of it, you already have your files on the sync target, so you don't need to clear it. I would say try the following:

  • Just to be safe, make a backup of your data by exporting to a JEX file
  • Also on your sever, make a copy of the sync target directory
  • Clear the profile of the apps that don't work (delete ~/.config/joplin-desktop)
  • Setup the apps again and sync

Normally that should work and you should get the latest data from the sync target.

An it made me return to my piano with an old ragtime I used to play :wink: …).

Nice :slight_smile: On my side I'm having fun trying to play Peacherine Rag at the moment.

EXCELLENT. Merci. That worked. Thanks for providing the profile location directory. Enjoy the weekend with your piano :wink:

Dear Team,

Couldnt find a solution to my issue related to the above one, hence posting and requesting help… I have a sync with webdav… I also have two macs with Joplin. I dont know what I was thinking so I ended up setting the sync as follows:
Mac 1: https://remote.com/joplin/
Mac 2: https://remote.com/officework

Unable to sync common notes between the two…

So I went ahead and created a new folder as follows:

And now, pasted all my notes from my original folders under this:

Now when I follow the instructions mentioned in the above solution, I dont see any data in Joplin synced… Is there any mistake at my end (with the directory structure etc?)… Any help in this regard is highly appreciated…

Thank you so much for Joplin

Stay Safe,

Same here, only on Android 10 with Joplin V2.1.3. At first, at typing in the webdav URL, I forgot to set the folder name. After changing it, sync still did not work! Only the upload of a test note to the server. After reading the above, I went into Android settings->apps->Joplin and cleared the memory and cache. After that all configuration was lost (as indented), I had to type it in again, and: Voila, there are my notes!