Joplin deletes local file

Dear All,

I tried to use Joplin to sync between my several PCs, I performed below steps, but I find it deletes my local file.

  1. I add my note from cuecards by copy and create note one by one, after copied some about 300 notes, it crashed.
  2. I don’t know how to recover, so I deleted all local notes(folder JoplinProfile) and the folder in cloud(WebDAV). then I created all notes again, this time I backed up by export before sync, but after some time I find some note are deleted. refer to below pictures, left is what it was.

Could you help please? there is no problem with the error, since my cloud is free, there are some limitation about requests every hour.


  • The version you are using. LATEST VERSION is not a version number!
    Joplin 1.0.201 (prod, win32)

Client ID: 0264fe9a2c604fffa4496fcf7dd8cb2c
Sync Version: 1
Profile Version: 28

Revision: e65af8c1 (master)

  • The operating system you are using.
    windows 10

Dear All,

I think I figured out what caused this issue.
It should be related to the WebDAV provider, it only support one time max 600 requests, so Joplin cannot finish even a single sync, the sync is cut unexpectedly, so next time, when Joplin would like to sync again, it finds some file in local but not in WebDAV, so it try to delete local files…I don’t know if this could be improved, such as sync a part only each time? when I try to use onedrive, although the first time I met “self signed certificate in certificate chain”, maybe due to I use Corporate PC, but when I tried again, it worked, I don’t know why.

I leave this post here to advise thoese who also try the same solution, since I cannot find the reason initially and have to copy all my notes again…that time I thougt Joplin was a fake note(sorry…).
the WebDAV I used initially is from, they do a lot of propoganda in some Chinese web site and their portal(, but they hide their free WebDAV has this side effect which may frustrating.


1 Like