Synchronizer: Error: Error 504 Gateway Timeout

Operating system


Joplin version


Desktop version info

Joplin 2.14.17 (prod, linux)

Client-ID: 1ee5bef17c5d49f9a0b84970990eca05
Sync-Version: 3
Profil-Version: 46
Unterstützter Schlüsselbund: Nein

Revision: 094175c

Backup: 1.4.0
Email Note: 1.2.2
Email Plugin: 1.0.0
Joplin Note Attachement rename: 1.2.2
joplin plugin app screen locker: 1.0.8
Menu items, Shortcuts, Toolbar icons: 1.1.0
Note Statistics: 1.0.4
OCR: 0.3.2

Sync target

Joplin Cloud

What issue do you have?

Hi folks
Newly installed Joplin Android-App does not sync from JoplinCloud down to Android target ca. 5500 notes. Experienced on 2 different Android devices (Pixel 6; Huawei MatePad Pro). It gives error "... Synchronizer: Error: Error 504 Gateway Timeout ...". Funfact: If I add a new note on the Pixel6, it gets eventually synced up to JoplinCloud and down to my Joplin-Desktop on Ubuntu 22.04.4 LTS jammy x86_64 - this is my main/central Joplin app.
Btw.: On the Linux-DT-side everything is synced since long - coming from Evernote with ca. 5'500 notes.
Gone thru all info, tried several times do delete/uninstall/reinstall on both Pixel6 and MatePadPro over the last 2 - 3 Weeks to no avail - need help.
Maybe should (how?) purge everything on JoplinCloud and then sync from Linux again? Need to know how to do that.
Thanks very much.


Log file

Bad-Gateway-504_14f9a2dd16e543f1b36cc165d28259cc.txt (77 KB)

It seems the connection may be slow? Is the Linux application running at the same time as the Android one? As that could cause one to lock the other, especially on a slow connection

Thanks Laurent.
No, in order to not get sync-locked, the Linux DT-app is shut completely down - only 1 single device is up with the Joplin Android app. I would keep it so, until all 3 devices - one after the other - would be synced-up and ready for normal work.
And no again, these are 3 devices each on its own 5G mobile connection.
Another funfact: I've also migrated another persons Evernote notes (ca. 3000+), also to a Linux Desktop, then to JoplinCloud and then to a Pixel6 Android. It took a long time for all the fotos and pdf, but eventually, everything was there and works as expected.

19:30 same day
In the meantime I found this conversation:

Might we be at a similar obstacle?

Link: 504 Gateway Timeout

I'd just like to get some pointers - and probably some know-how as well - on how I should proceed in order to get my problem mitigated.
It's nice of course, that at least my Linux-Joplin Desktop app works, but my 2 Android devices are still a bust.
I've tried several times to de-install / re-install Joplin on both Adroid devies - to no avail - it woudn't even start syncing...
For me it's very hard to deduce / decide where the problem lies: Is it on Android or is it on the JoplinCloud? If it's JC, then how can I get all the synced data in the cloud cleaned out?
Thank you.

Are you still having these gateway timeout errors with Joplin Cloud? If so would you mind posting your log here?

Yes, I still have them - nothing has changed.

Btw.: I've attached the log to my very first post. but here is a brand- new one plus a screenshot from the same device (Tablet) which shows, that nothing goes.

Hope this helps.

Thank you.

Apr 6, 2024, 15:13 by

mobile-log.log (125 KB)

Hello, I believe this should be fixed now, apologies for the delay. If you can please give it another try and let me know if you're still experiencing this issue

Hello Laurent
Whatever you did, did the trick - I've since synced 2 Android devices with my full 5'500+ notes. I'm now pretty happy, that I'm able to use JoplinCloud as my sync-target for all client instances and I thank you.
What was the problem?
Best regards.

Some accounts, including yours, hit an edge case due to the number of notes and when it was created, which means a particular database query was very slow on the first synchronisation.

This has been optimised and this query should now go from taking several minutes to a few milliseconds. However if you notice any other similar issue feel free to let me know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.