Error 504 Gateway- Joplin on Windows

Operating system


Joplin version


Desktop version info

Joplin 2.12.19 (prod, win32)
Sync Version: 3
Profile Version: 43
Keychain Supported: Yes
Revision: 7081046

Sync target

Joplin Cloud

What issue do you have?

Set up a new windows computer to my Joplin Cloud. Iphone and Linux are syncing but Windows is not. It can upload to cloud but when downloading getting this error. Tried on two different windows pc's.

Last error: Error: Error 504 Gateway Timeout: <html> <head><title>504 Gateway Time-out</title></head> <body> <center><h1>504 Gateway Time-out</h1></center> <hr><center>nginx/1.18.0 (Ubuntu)</center> </body> </html>


Hi, could you try again and see if it works? If not please provide the full log

Tried again and same issue. Also installed Joplin on my Ipad and it's getting the same error. So seems to be related to anything that hasn't synced with it yet.

log.txt (13.2 KB)

Some other things I tried:

  • Backed up notes on computer. Deleted all notes/Synced with cloud/ and tried to get the other devices to connect. Did not fix issue.
  • Deleted the app from my phone (that was working) and reinstalled it. When Trying to sync got the same 504 Gateway error. Was able to push notes to cloud but not retrieve.
  • Changed my Joplin Cloud Password and put password on all devices. Did not fix issue.

This thread here had the same issue and it seems the issue here fixed mine as well. Joplin Cloud Sync Error on new linux install

Win 11, Joplin 2.13.15.
First installation, no local data.
Sync enabled. Encryption password entered correctly.


Other Joplin clients in this local network (Linux, Win10) are syncing perfectly.

Where do I find the log.txt file ??