Can't sync on 2.14.22 all of a sudden!

Operating system

macOS

Joplin version

2.14.22

Desktop version info

Joplin 2.14.22 (prod, darwin)

Client ID: 4aca3a9777c34272a24dd81ef9b39ee8
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: e579eb9

Backup: 1.4.0

Sync target

Dropbox

What issue do you have?

As of this morning, I'm getting this message: "In order to synchronise, please upgrade your application to version 3.0.0+"

However, I think v3 and up requires a later version of Mac. I'm on High Sierra (10.13.6) and CANNOT upgrade because this is a hackintosh. Please tell me there's a way to re-enable sync!

One of your clients has upgraded the sync target because it was upgraded to v3.

If you can't upgrade a client to v3 then you will need all your clients to be on v2 (i.e. downgrade any v3 clients you have that you plan to sync with this v2 system).

Before you do anything you should back up your local client data to make sure you have a known good copy of your notes. There is never too much overkill here, I take a copy of my ~/.config/joplin-desktop, a manual JEX export of everything and whatever backups the simple backup plugin has made.

You cannot downgrade the sync target - there is a (destructive) option within Joplin to destroy the target and re-upload (Options > Synchronisation > Show advanced settings > Re-upload local data to sync target), that replaces it with one for the v2 system.

Once that is done you should be OK to re-connect any other v2 clients but you need to make sure you leave them on v2 and don't allow them to auto update to v3.

1 Like

Yes, I've got about 5 or 6 Windows PCs also hitting that same Dropbox target, and they're all on v3.xx. Bummer. I think I may just have to remote desktop into one of those PCs from the Mac. Thanks for the prompt reply.

Oh I forgot to mention, you might find that the v2 clients can't work with the v3 database in which case you might need to just move/delete that client's local data and just let it sync from the "new" sync target.

1 Like

I tried this solution and it didn't work for me.

I'm on OS 10.14.6. I blindly tried to update to v3. In so doing, my current version got erased but then I got the message that v3 was incompatible with OS 10.14.6. So I installed v 2.14.22
and followed the tips in this post, but I still got the message: "In order to synchronise, please upgrade your application to version 3.0.0+".

Then I tried "Delete local data and re-download from sync target" which I found in Joplin > Preferences > Synchronisation > Show advanced settings > Delete local data and re-download from sync target. That didn't work either.

Any other suggestions? Or am I doing something wrong?